Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    It worked! Thank you. :D
  3. Offline


    if(plugin.Permissions.getGroupPermissionBoolean(world.getName(),plugin.Permissions.getGroup(world.getName(), invPlayer.getName()), "weather.strike.invulnerable"))
    When the method return false o true?
  4. Offline


    Work for 733??
  5. Offline


  6. Offline


    Every time I break a block I get :
    14:38:08 [GRAVE] Could not pass event BLOCK_BREAK to Permissions
            at com.nijiko.permissions.Control.getGroups(
            at com.nijikokun.bukkit.Permissions.Listener.onBlockBreak(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.ItemInWorldManager.d(
            at net.minecraft.server.ItemInWorldManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
            at net.minecraft.server.NetworkManager.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(
    and same thing for block place
    craftbukkit 733
  7. Offline


    Same, Please help!
  8. Offline


    Working fine for me on #733. Are you guys running any plugins which could be causing this? Like a worldguard or plugin manager or something?
  9. Is it possible to use MySQL with this Version?
  10. Offline


    Here is my plugins list :
    AdminMode        Graveyard-0.3  MessageChanger  PermissionsPlus
    CommandBook      HeroChat       MobileAdmin     Tombstone
    dispnamechanger  Interest-1.6   NoExplode       WorldEdit
    dynmap           Landmarks      Permissions
    I've tried without PermissionsPlus, but it's the same
  11. Offline


    The only plugin I am running the same as you is WorldEdit, I think that is what caused the problem before, Gimme two minutes and I will test
  12. Offline


    Yeah I would say that's the culprit.
  13. Offline


    Nope, Didnt help FML

    Ill give it a go later, Ive got a lesson now :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  14. Offline


    You can find out permission is inherited by a group or has been awarded to the player with the API?
  15. Offline


    When are you going to update for b733
  16. Offline


    It's perfectly compatible with 733.
  17. Offline


    Seems to be working fine for me so far
  18. I think WorldEdit/WorldGuard is stopping inheritence from functioning.
  19. Offline


    i keep getting a, "you don't have permission to do this" or "you don't have permission to use this" eorr when i place blocks or even just right click a block any idea why?
  20. Offline


    After removing essentials spawn, it still doesn't make people guests as default...
  21. Offline


    Well i just tried to install this plugin on 733 with no other plugins and it did not work. For 677 ir works fine :)
  22. Offline


    oh ok thank you but it was working fine but when i updated my server it stopped working
  23. Offline


    Confirmed 733

    But I want to disable /give 46 or have some plugin for /item, Is there such a plugin? I have an op but I don't want him to have access to some items, including 46
  24. Offline

    Chris Lewis

    Is there any kind of error? Make sure your player is using /buy or /sell as IconomyChestShop requires you to be in the right mode for you to buy or sell. by default that plugin puts you in buy mode
  25. Offline


    I tried disabling ALL my plugins, After that it still done this :S
  26. Offline


    i had the same block placement issues... I checked and rechecked by adding and removing plugins. It's world edit. Everything else works fine but worldedit causes this issue. I tried to leave a message in their thread but they don't listen

    The problem with removing worldedit on my server is all the protections from essentials get removed.. Permissions works damn well though.

    Anyone have any idea on what plugins to use instead of essentials/worldedit I'm all ears.

    ben remove world edit, reupdate your server to vanilla, readd every plugin but it. Should be disco after that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  27. Offline


    is this plugin working on Build 733 because i am running and somehting is causing "you don't have permission to do this" errors when right clicking blocks or putting blocks down. this only happens to people that do not have full admin powers.
  28. Offline


    Ill try this now

    This was caused by CraftBook for me, If you dont have the permissions nodes, No matter what someone does it say they dont have permission and still lets ttem do it

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  29. Offline


    Please could someone who knows this stuff try to help me fix this...
    Whenever i load my server, i get this:

    16:52:03 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
    16:52:03 [INFO] Preparing level "Matts World 3"
    16:52:03 [INFO] Preparing start region
    16:52:04 [INFO] [Permissions] (Phoenix) was Initialized.
    16:52:04 [SEVERE] java.lang.Integer cannot be cast to java.lang.String initializing Permissions v2.7 (Is it up to date?)
    java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String
    at com.nijiko.permissions.Control.load(
    at com.nijiko.permissions.Control.load(
    at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    16:52:04 [INFO] IBICF is properly working.
    16:52:04 [INFO] [Permissions] version [2.7] (Phoenix) loaded

    My YAML file all looks okay and works fine in a parser, and as you can see, the only other plugin that i am using is IBICF, so I would appreciate any help.
  30. Offline


    o wow that was the only plugin i didn't test...thanks for that lol thats been pondering me for about 4 hours now...

    did you try reinstalling the permissions plugin first?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  31. Offline


    Is Matts World 3 in single quotes ' in your YAML file?
Thread Status:
Not open for further replies.

Share This Page