Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    TheYeti

    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Download:
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!


    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.




    Changelog
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed permissions.info as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    [/SPOILER]
     
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline

    Truecorruptor

    WOOT WOOT. IDK whatwas going on but i deleted admin category and redid it all. Thx for your help Regalia. You told me to re type it, and i did. Didnt work so i retyped whole categorey and it worked. Id give you a big kiss if you were right beside me :)
    Now join my server try this link for info http://www.minecraftforum.net/viewtopic.php?f=1025&t=301806

    Its an rpg server that now works because of of the nice people of this post.
     
  3. Offline

    paully104

    Working on 714 with me. However the plugin was not updating by doing /permissions reload all in game the permissions then stuck and everything worked.

    Also in the default remove the -foo.bar before your entrys!
     
  4. Offline

    RegaIia

    Haha I appreciate the offer, but I got my own server as it stands. Good luck with your server, sounds like a lot of fun
     
  5. Offline

    toon7

    u sure that will work?
    because i still able to use it :(

    ****
    everybody can use give and i somehow :(
    also god and back after this
    Code:
    groups:
        Default:
            default: true
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
            permissions:
                - 'foo.bar'
                - 'essentials.mail'
                - 'essentials.sethome'
                - 'essentials.home'
                - 'lockette.user.create.*'
                - 'lc.level.*'
                - 'lc.shout'
                - 'wormhole.use.dialer'
                - 'wormhole.use.sign'
                - 'wormhole.build'
                - '-essentials.god'
                - '-essentials.back'
                - '-ItemSpawn.Essentials'
        Moderator:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Default
            permissions:
                - 'essentials.kick'
                - 'essentials.ban'
                - 'essentials.tp'
        Admins:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
            permissions:
                - '*'
                - 'dropchest.*'
                - 'lockette.admin.create.*'
                - 'lockette.admin.break'
                - 'lockette.admin.bypass'
                - 'lockette.admin.snoop'
                - 'lockette.admin.reload'
                - 'lc.admin'
                - 'dropchest'
                - 'dropchest.create'
                - 'dropchest.remove'
                - 'dropchest.radius.set'
                - 'dropchest.radius.setBig'
                - 'dropchest.which'
                - 'dropchest.teleport'
                - 'dropchest.filter'
                - 'dropchest.destroy'
                - 'dropchest.protect'
                - 'dropchest.moderator'
                - 'mothernature.command.help'
                - 'mothernature.command.version'
                - 'mothernature.command.reload'
                - 'mothernature.command.rain'
                - 'mothernature.command.thunder'
                - 'mothernature.command.lightning'
                - 'mothernature.command.sun'
                - 'mothernature.command.umbrella'
                - 'mothernature.wand'
    pls tell whats wrong thx
     
  6. Offline

    Popupkiller

    I am having problems adding permissions to my permissions 2.7 file.
    They dont seem to actually do anyting.
    If I am OP, they work, but if I'm not, they dont, even if I am set to the right group.

    Is there anything wrong with this format?
    The Parser doesnt give off any errors.

    Code:
        Builder:
            default: false
            info:
                prefix:
                suffix:
                build: true
            inheritance:
            permissions:
                - 'essentials.motd'
                - 'essentials.back.ondeath'
                - 'essentials.portal'
                - 'essentials.tpa'
                - 'essentials.tpaccept'
                - 'essentials.tpdeny'
                - 'essentials.msg'
                - 'essentials.afk'
                - 'essentials.rules'
                - 'essentials.me'
                - 'essentials.list'
                - 'essentials.mail'
                - 'essentials.mail.send'
                - 'essentials.helpop'
                - 'essentials.whois'
                - 'essentials.nick'
                - 'essentials.clearinventory'
                - 'essentials.chat.question'
     
  7. Offline

    Sol_Prower

    I'm getting this error when I try to run this with Bukkit build #709

    Code:
    2011-04-23 17:54:58 [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':
    java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:136)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:160)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:108)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:85)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:217)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:144)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:259)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: while parsing a block collection
     in "<reader>", line 69, column 13:
                    - 'essentials.rules'
                    ^
    expected <block end>, but found Scalar
     in "<reader>", line 72, column 16:
                    - 'essentials.motd'
                       ^
    
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(ParserImpl.java:520)
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
        at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:203)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:158)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
        at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
        at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:124)
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
        at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfiguration.java:58)
        at com.nijikokun.bukkit.Permissions.Permissions.<init>(Permissions.java:132)
        ... 13 more
    Plus here's my .YML file http://dl.dropbox.com/u/26496570/world1.yml
     
  8. Offline

    Truecorruptor

    Aha had same porblem. Get notepad++ because its easier. Then rewrite the section that the problem occurs. With notepad++ it tells you what line your on so it is easiier. My problem was with my admin group. Deleted it and made a new. Then it worked
     
  9. Offline

    Cookies326

    For some reason despite fixing my General problem, nobody has permission, only me, the admin(because I think I have '*' and maybe because I'm an op(s)).

    Could someone help out?
     
  10. Offline

    Sol_Prower

    Rewrote it and it still gives me errors on the same line T.T
     
  11. Offline

    tom

    Well -ItemSpawn.Essentials isnt the exact node, i think the exact node would be something like - '-essentials.give'
     
  12. Offline

    Maxis010

    It's a bug any coder will run it to at some time or another
    Code:
    expected <block end>, but found Scalar
    in "<reader>", line 72, column 16:
                    - 'essentials.motd'
    
    This is your problem, the error is saying illegal end of line
    Illegal end of line errors are almost always caused by the line before
    Here is the line before the error, and the error line
    Code:
                - 'essentials.msg
                - 'essentials.motd'
    
    You are missing a ' from essentials.msg

    Sorry for the long winded explanation but I hope (yet at the same time doubt) that this will help other people with EOL errors

    EDIT: You also need to fix line
    112 - 'localshops.manage
    Else you will get another EOL error
     
  13. Offline

    alexhoodg

    does permissions 2.1 work?
     
  14. Offline

    MCWolfCraft

    Hi if i could get a fast reply but is there any ingame commands to add permissions?
     
  15. Offline

    alexhoodg

    yea i got this one 2.7 but it says i do not have permission whats that about i did everything correct the command i tried was manpromote in essentials to promote someone to builder in permissions

    plz someone help me
     
  16. Offline

    Sol_Prower

    Thank you very much! It's now working.
     
  17. Offline

    Fellshadow

    A tutorial or something on how to use this would be nice.

    On my server I want the admins to be able to use worldedit/worldguard but no one else. How would I go about doing this?
     
  18. Offline

    alexhoodg

    i want to know how to make myself admin in the first place im op and thats all i can do
     
  19. Offline

    Zerco

    Add yourself to the Admin(or what you have it as) group under users:

    There's a wiki at the top, and a guide below the credit section at the bottom. You would assign your admins to the Admin group, and give the admins either - '*' denoting ALL permissions or just the WorldGuard/WorldEdit ones. Anyone that doesn't have the node for WG/WE wouldn't be able to use them.
     
  20. Offline

    LanToaster

    Thanks. :) Thats what i´ve been looking for.
     
  21. Offline

    bentheexo

    Code:
    04:41:55 [SEVERE] Could not pass event BLOCK_PLACE to Permissions
    java.lang.NullPointerException
            at com.nijiko.permissions.Control.getGroups(Control.java:620)
            at com.nijikokun.bukkit.Permissions.Listener.onBlockPlace(Listener.java:43)
            at org.bukkit.plugin.java.JavaPluginLoader$25.execute(JavaPluginLoader.java:350)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:257)
            at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:84)
            at org.bukkit.craftbukkit.event.CraftEventFactory.callBlockPlaceEvent(CraftEventFactory.java:68)
            at net.minecraft.server.ItemSign.a(ItemSign.java:57)
            at net.minecraft.server.ItemStack.placeItem(ItemStack.java:56)
            at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:217)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:504)
            at net.minecraft.server.Packet15Place.a(SourceFile:57)
            at net.minecraft.server.NetworkManager.a(NetworkManager.java:195)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:73)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:370)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    
    Not sure if this is because of CB build 714 or not, but this is what happens when you attempt to create "stargates" http://forums.bukkit.org/threads/tp...a-portal-plugin-b670.3927/page-24#post-236510
     
  22. Offline

    Cookies326

    Yet again, after thinking that General.jar was the problem however it still wasn't the main problem. Everyone still doesn't have permissions(apart from me being an Admin and is a Op), can anybody care to help? Thanks in advanced

    Permission COnfig file:
    Code:
    groups:
        Default:
            default: true
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
            permissions:
            - 'enable.protection.doors'
            - 'essentials.help'
            - 'essentials.home'
            - 'essentials.motd'
            - 'essentials.sethome'
            - 'essentials.spawn'
            - 'explosion.protection.all'
            - 'falsebook.*'
            - 'HomeX.*'
            - 'lockette.create.*'
            - 'lwc.protect'
            - 'SignOwner.getMessage'
            - 'TentThis.commands.setOwnSchema'
            - 'tombstone.large'
            - 'tombstone.lwc'
            - 'tombstone.quickloot'
            - 'tombstone.sign'
            - 'tombstone.use'
            - 'tpp.jump.*'
            - 'tpp.request'
            - 'wolfnames.set'
            - 'wolfnames.show'
            - 'general.away'
        Trustee:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Default
            permissions:
            - 'enable.messages.*'
            - 'FD.admin'
            - 'griefalertr.view'
            - 'TentThis.commands.setLimit'
            - 'tpp.others.*'
            - 'tpp.tp.*'
            - 'warp.create.*'
            - 'warp.to.*'
            - 'general.time'
            - 'general.playerlist'
            - 'general.who'
            - 'general.away'
            - 'general.getpos'
            - 'general.tell'
            - 'general.spawn'
            - 'general.teleport'
            - 'general.teleport.other'
            - 'general.teleport.coords'
            - 'general.getpost.*'
            - 'general.clear'
        Moderator:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Trustee
            permissions:
            - 'essentials.give'
            - 'essentials.item'
            - 'essentials.list'
            - 'essentials.tp'
            - 'essentials.tphere'
            - 'lockette.admin.break'
            - 'TentThis.commands.setLimit'
            - 'tombstone.*'
            - 'tpp.mod.*'
        Admins:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
            permissions:
                - '*'
        SemiAdmin:
            default: false
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Default
            permissions:
            - 'admincmd.player.clear'
            - 'admincmd.player.kill'
            - 'delayedstop.cancel'
            - 'delayedstop.start'
            - 'godPowers.die'
            - 'godPowers.godmode'
            - 'godPowers.godmodeOnLogin'
            - 'godPowers.heal'
            - 'godPowers.inferno'
            - 'godPowers.jesus'
            - 'godPowers.maim'
            - 'godPowers.slay'
            - 'godPowers.superjump'
            - 'lwc.mod'
            - 'vanish.vanish'
            - 'vanish.vanish.list'
            - 'tpp.admin.*'
            - 'general.spawn.*'
            - 'general.*'
            - 'general.heal'
            - 'general.hurt'
            - 'general.clear.*'
            - 'general.weather'
    
    
    ##
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can also have a prefix and suffix as seen with Herpina
    ##
    users:
        EXAMPLE:
            group: Trustee
            permissions:
    Server log:
    Code:
    2011-04-24 09:31:42 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-686-g71ef92a-b714jnks (MC: 1.5_02)
    2011-04-24 09:31:42 [INFO] Preparing level "world"
    2011-04-24 09:31:42 [INFO] Preparing start region
    2011-04-24 09:31:43 [INFO] LWC    Loading shared objects
    2011-04-24 09:31:44 [INFO] LWC    Native library: plugins/LWC/lib/native/Mac/x86_64/libsqlitejdbc.jnilib
    2011-04-24 09:31:44 [INFO] [Permissions] (Phoenix) was Initialized.
    2011-04-24 09:31:44 [INFO] [General-0.0] Loaded.
    2011-04-24 09:31:44 [INFO] [AfkBooter] Permissions detected, attaching.
    2011-04-24 09:31:44 [INFO] [AfkBooter] Version 0.7.1 is loaded.
    2011-04-24 09:31:44 [INFO] [AfkBooter] Kick timeout 60 sec, exempt players: Pro_Cookies, name2, name3
    2011-04-24 09:31:44 [INFO] AntiHack version 1.5 is enabled!
    2011-04-24 09:31:44 [INFO] AppleTree activated.
    2011-04-24 09:31:44 [INFO] [AutoPlant] version 1.51 is enabled!
    2011-04-24 09:31:44 [INFO] Backup v1.2b was sucessfully loaded!
    2011-04-24 09:31:44 [INFO] [BurningMobs] Monitoring thread started successfully!
    2011-04-24 09:31:44 [INFO] [BurningMobs] v0.2 loaded successfully!
    2011-04-24 09:31:44 [INFO] [ChocolateFever] version 1.1 is enabled!
    2011-04-24 09:31:44 [INFO] ChunkRegenerate version 1.0 is enabled with permissions!
    2011-04-24 09:31:44 [INFO] Commands Logging version 1.0 is enabled!
    2011-04-24 09:31:44 [INFO] DefaultCommands 2.5.5 is enabled. Using Permissions.
    2011-04-24 09:31:44 [INFO] [DelayedStop] Enabling Delayed Stop v0.16
    2011-04-24 09:31:44 [INFO] [DelayedStop] Permission system found
    2011-04-24 09:31:44 [INFO] [DelayedStop] version 0.16 enabled
    2011-04-24 09:31:44 [INFO] DropBonus v2.4  has been enabled.
    2011-04-24 09:31:44 [INFO] Loaded ExExplosions version 1.0.0.0
    2011-04-24 09:31:44 [INFO] Found Diamonds STARTED
    2011-04-24 09:31:45 [WARNING] [General-3.3.3] An error occured: either general.kits does not exist or it could not be read; kits ignored
    2011-04-24 09:31:45 [INFO] [Permissions] version [2.7] (Phoenix)  loaded
    2011-04-24 09:31:45 [INFO] [General-3.3.3]  Using [Permissions 2.7] for permissions.
    2011-04-24 09:31:45 [INFO] [General-3.3.3] [Codename: Dvorak] Plugin successfully loaded!
    2011-04-24 09:31:46 [INFO] [General-3.3.3] [Help 0.2] support enabled.
    2011-04-24 09:31:46 [INFO] GlassHurt version 1.0 is enabled!
    2011-04-24 09:31:46 [INFO] tnt:
    2011-04-24 09:31:46 [INFO] 46
    2011-04-24 09:31:46 [INFO] TNT
    2011-04-24 09:31:46 [INFO] onPlace
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] false
    2011-04-24 09:31:46 [INFO] b
    2011-04-24 09:31:46 [INFO] c
    2011-04-24 09:31:46 [INFO] tnt(for exploding):
    2011-04-24 09:31:46 [INFO] 46
    2011-04-24 09:31:46 [INFO] TNT
    2011-04-24 09:31:46 [INFO] onBreak
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] true
    2011-04-24 09:31:46 [INFO] false
    2011-04-24 09:31:46 [INFO] 9
    2011-04-24 09:31:46 [INFO] 7
    2011-04-24 09:31:46 [INFO] [GriefAlertR] is unloaded.
    2011-04-24 09:31:46 [INFO] GriefAlertR version 0.71 by Gandalf is enabled!
    2011-04-24 09:31:46 [INFO] Please visit http://wdgaming.net for our Minecraft server.
    2011-04-24 09:31:46 [INFO] [HELP] 44 extra help entries loaded
    2011-04-24 09:31:46 [INFO] [HELP] Permissions enabled using: Permissions v2.7
    2011-04-24 09:31:46 [INFO] [HELP] Help 0.2 enabled
    2011-04-24 09:31:46 [INFO] [HeroicDeath] 1.7.3.148 enabled.
    2011-04-24 09:31:46 [INFO] HomeX enabled
    2011-04-24 09:31:46 [INFO] [iChat] Found Permissions (v2.7)
    2011-04-24 09:31:46 [INFO] iChat (v2.2.3) enabled
    2011-04-24 09:31:46 [INFO] [iWatch] iWatch version 0.5 is enabled!
    2011-04-24 09:31:46 [INFO] [iWatch] Settings Loaded!
    2011-04-24 09:31:46 [INFO] Lockette version 1.3.6 is being enabled!  Yay!  (Core version 1.0)
    2011-04-24 09:31:46 [INFO] Lockette: Detected craftbukkit build [714] ok.
    2011-04-24 09:31:46 [INFO] Lockette: Linked to Permissions plugin version 2.7
    2011-04-24 09:31:46 [INFO] Lockette: Ready to protect your containers.
    2011-04-24 09:31:46 [INFO] LWC    Loaded 116 locale strings (0 overrides)
    2011-04-24 09:31:47 [INFO] LWC    Using Nijikokun's permissions plugin for permissions
    2011-04-24 09:31:47 [INFO] LWC    Loading SQLite
    2011-04-24 09:31:47 [INFO] SQLite    Using: Native
    2011-04-24 09:31:47 [INFO] LWC    At version: v2.30
    2011-04-24 09:31:47 [INFO] NaturalGiants version 1.1 is enabled!
    2011-04-24 09:31:47 [INFO] NetherPortal 0.6.2 enabled.
    2011-04-24 09:31:47 [WARNING] [NoCheatPlugin] version [0.7.7] couldn't find CrafTIRC plugin. Disabling logging to IRC.
    2011-04-24 09:31:47 [INFO] [NoCheatPlugin] version [0.7.7] is enabled with the following checks: moving speedhack bedteleport
    2011-04-24 09:31:47 [INFO] NoExplode version 1.4 is enabled!
    2011-04-24 09:31:47 [INFO] NoFire version 1.1 is enabled!
    2011-04-24 09:31:47 [INFO] NoTNT V1.1 - Loaded configuration file.
    2011-04-24 09:31:47 [INFO] NoTNT V1.1 - enabled.
    2011-04-24 09:31:47 [INFO] [oreRespawn] world enabled!
    2011-04-24 09:31:47 [INFO] Database class loaded
    2011-04-24 09:31:47 [INFO] oreRespawn version 0.2 is enabled!
    2011-04-24 09:31:47 [INFO] [SpawnMob] Permission system found, plugin enabled
    2011-04-24 09:31:47 [INFO] [Tele++] version [1.3.3a] loaded
    2011-04-24 09:31:47 [INFO] Tombstone v.1.2.3 is enabled.
    2011-04-24 09:31:47 [INFO] [Tombstone] Using Permissions (v2.7)
    2011-04-24 09:31:47 [INFO] [Tombstone] Using LWC (v2.3)
    2011-04-24 09:31:47 [INFO] Vanish 1.5.2 loaded.
    2011-04-24 09:31:47 [INFO] Weather Man - On Air!
    2011-04-24 09:31:47 [INFO] WelcomeMe version 1.1.1 is enabled!
    2011-04-24 09:31:47 [INFO] Whitelist: Trying to load whitelist and settings...
    2011-04-24 09:31:47 [INFO] done.
    2011-04-24 09:31:47 [INFO] Whitelist version 2.7 is enabled!
    2011-04-24 09:31:47 [INFO] [WolfNames]: Permissions plugin detected! Using Permissions plugin for permissions.
    2011-04-24 09:31:47 [INFO] [WolfNames] successfully hooked onto Permissions Plugin.
    2011-04-24 09:31:47 [INFO] [WolfNames] version v1.1 (Razor) successfully enabled and loaded
    2011-04-24 09:31:47 [INFO] [xAuth] Loading player accounts..
    2011-04-24 09:31:47 [INFO] [xAuth] Done! Loaded 6 Accounts!
    2011-04-24 09:31:47 [INFO] [xAuth] v1.2.3 Enabled!
    2011-04-24 09:31:47 [INFO] Done (0.469s)! For help, type "help" or "?"
    
    Clearly there isn't any error, so I don't get why nobody can do anything. Thanks in advanced whoever is helping out.
     
  23. Offline

    alexhoodg

    i have added myself and several other ppl to it under users in permissions, tested it in ymal parsar, made sure its loaded in the cmd. i dont know why its not working
     
  24. Offline

    Zerco

    Post it. Use the [/code] and [/spoiler] tags to save the formatting and to save page space.
    So it should look like:
    Show Spoiler

    Code:
    Code goes here \o/
    


    I'm running out of ideas, try shifting the inherited groups to the left 4 spaces so that they are on par with the permissions. So it should look like:
    Code:
    groups:
        Moderator:
            default: false
             info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
            - Trustee
            permissions:
            - 'essentials.give'
    
    edit: Fixed spacing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jul 17, 2016
  25. Offline

    blindsarcasm

    You can get PermissionsPlus or Yeditor, I suggest the former, as the latter likes to disrupt the formats.

    Also, you removed the need for the commas (') correct? It removes them for me when I run my server.
     
  26. Offline

    Zerco

    Yea permission nodes just need the " - " now, not necessary to surround them with ' anymore. I just do it out of habit, it doesn't change it, seems to work either way.
     
  27. Offline

    chernobyl360

    permissions wont work on #714. everything is setup 100% . it seems it just wont detect on #714
     
  28. Offline

    Celtic Minstrel

    @Truecorruptor & @RegaIia - The parser is not infallible about reporting where the error occurred. If it says there's an error on line 193, especially if it's pointing at the beginning of the line, it's quite likely that the error is actually on line 192.
     
  29. Offline

    palz2015

    Does this work with 1.5 (CB 709+)? I really need to know.
     
  30. Offline

    FrozenBrain

    Yes, it is working with the newer bukkit builds.
     
  31. Offline

    Celtic Minstrel

    They are called quotes, not commas, and technically they never were necessary for most cases; Nijikokun probably just said to include them because there are some situations where they are necessary (for example, I think '*' does need it?). Other things that would need quotes are group names that include colons or square brackets, or user/group names that consist only of numbers. Or even permissions nodes that are numbers, though I doubt any of those exist.
     
Thread Status:
Not open for further replies.

Share This Page