Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    You don't need the 's anymore. just - lottery.admin.draw as opposed to your - 'lottery... etc.
    You need to post the error in your console, though, not the config. That is what it meant by server log. Then someone can probably tell you exactly what it is.
  3. Offline



    You are half right and half wrong You dont need the ' ' but you can have them if you want it will not hurt. it is not the problem with his file. so you can now stop wasting his time telling him he has to remove them....

    Yes I can help you out I have already spotted a few problems with your config. the main problem being you dont have the info: section in all your groups but you have the prefix ect that is meant to be inside the info.

    so... each groups top part before the permissions should look like this: But with names ect changed.

            default: false
            info:                         # <<<<< this line ur missing Remove this text from # to #
                prefix: '&c(&8Banned&c)'
                suffix: '&f'
                build: false
    Another thing i noticed with your file is that you are not using inheritance What this means is that you have the same permissions for every group as well as some added for the higher ranks, that works but you could make your life easier by using inheritance. What inheritance dose is it gives the commands from another group to the group you are making so say I have a group called Donator and they have the permission*

    then when i go to make the next group i want admin to have every single command donator has Plus a few more i do this

             default: false
                 prefix: '&c(&8Banned&c)'
                 suffix: '&f'
                 build: false
                - Donator               # <<<<<< this means admin has all the commands Donator has and you do not need to put* Under the admins permissions #
    1 last thing your default group has inheritance But it is from its self and the line is missing a space this will make your file not work you have -default there it needs to be blank it cant inherit from its self .......

    I wish i could charge 1 $ for every file i fix Then i would hand out fixed files ready for use all optimized nicely

    Could some 1 please tell me how to make the global files work I assume i have to put the info into the files the plugin made but how to i make the world respond to the global's demands :/

    Because coppy/inheritance of worlds fails 100% sucks because its really what i need.

    DUDE you seem to be just copy and pasting the old files into the new plugin It will not work like that did you even read the Converting guide in the First post. it clearly shows how to put the users in the users file here:

    Derpina:                 # User's name. Must be the same in their Minecraft username.
        info:                # Info nodes
            prefix: '&4'
        groups:              # Parent groups
            - Admins
        permissions:         # Permission nodes
            - '-derp.derp'
    now lets simplify that wo what you will actually need in most cases.

    Derpina:                 # User's name. Must be the same in their Minecraft username.
        groups:              # Parent groups
            - Admins       # Must be - GroupName Capitals are importand check your groups file.
    Remove any thing after a #

    I have helped a bunch of people Can some 1 please now help me :(

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 10, 2018
  4. Offline


    Ugh, im getting so fed up with this plugin. it keeps breaking my yaml.
    I start out with somthing like this
    - the group
    and it works great.... then suddenly. it changes itself to

    group: the group

    and alas, it no longer works. please reply what me erorr is or if the plugin is messed up :S
    (dont lecture me on format. i know how its supposed to go)
  5. Offline


    Because that whole reply wasn't a waste of time...
  6. Offline


    Are there nodes for regular SMP server commands like "/give" ? I have tried 'minecraft.give' but that has not worked so far. Any help is appreciated
  7. Offline



    Hi RustyDagger... you've helped me! So here is how I'm using the globals.... and its dead easy. Can't believe I struggled with it!!

    So, All commands that I want to share with multiple worlds (or a single world) I place in the globalGroups file.

    Here is my globalGroups.yml file:
            default: False
                prefix: '&4'
                suffix: ''
                build: True
                interact: True
              - 'Moderator'
              - '*'
              - '-lc.level.*'
            default: False
                prefix: '&0'
                suffix: ''
                build: True
                interact: True
              - 'Builder'
              - 'admincmd.*'
              - 'lc.admin.*'
               - '-lc.level.*'
            default: True
                prefix: '&0'
                suffix: ''
                build: True
                interact: True
            inheritance: 'null'
              - 'SpawnX.*'
              - 'lc.level.*'
              - 'lc.shout'
    Here is my groups.yml file that is inheriting from globalGroups.yml:
            default: True
                prefix: ''
                suffix: ''
                build: True
                interact: True
                - 'DestroySelf'
            default: False
                prefix: ''
                suffix: ''
                build: True
                interact: True
            permissions: []
            default: False
                prefix: '*'
                suffix: '*'
                build: True
                interact: True
            permissions: []
    As you can see... both files contain the same exact names. And you can see that I have nothing entered in any of groups.yml's inheritances! Not sure why this works, but it does!
    Also notice that I have DestroySelf as a permission for Builders in the groups.yml file. In this world people can use that permission, but if I didn't want them to us it in the nether then I would leave it out of the group.yml file for the nether world.
  8. Offline


    I am trying to disable building by the global group Default in nWorld. The Default group has the build setting as true in globalGroups.yml but it is false in the nWorld groups.yml, yet they can still build.

    globalGroups.yml -

    nWorld groups.yml -
  9. Offline


    Can't seem to get Permissions 3.1.5 linked with MySQL properly


            type: SQL
            dbms: 'MYSQL'
            uri: 'jdbc:mysql://' # Change Port if Needed
            username: 'minecraft'
            password: 'Passw0rd1'

    when i run the following i see the following in my server console:
    minecraft minecraft # ./
    148 recipes
    16 achievements
    16:58:00 [INFO] Starting minecraft server version Beta 1.6.6
    16:58:00 [INFO] Loading properties
    16:58:00 [INFO] Starting Minecraft server on *:25565
    16:58:00 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-823-gb9d0b04-b860jnks (MC: 1.6.6)
    16:58:00 [INFO] Preparing level "top"
    16:58:01 [INFO] Preparing start region for level 0
    16:58:02 [INFO] Preparing spawn area: 32%
    16:58:03 [INFO] Preparing spawn area: 77%
    16:58:03 [INFO] Preparing start region for level 1
    16:58:04 [INFO] Preparing spawn area: 20%
    16:58:05 [INFO] Preparing spawn area: 73%
    16:58:05 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] Initializing Permissions 3 SQL interface.
    16:58:06 [INFO] [Permissions] (Yeti) was initialized.
    16:58:06 [INFO] [Permissions] version [3.1.5] (Yeti)  loaded
    16:58:06 [INFO] [Permissions] SQL Interface enabled!
    16:58:06 [INFO] Done (0.589s)! For help, type "help" or "?"
    Looks all good but looking into my database where all the values should be stored...
    mysql> show databases;
    | Database           |
    | information_schema |
    | permissions        |
    | test               |
    3 rows in set (0.00 sec)
    mysql> use permissions
    Database changed
    mysql> show tables;
    Empty set (0.00 sec)
    No tables get created... All other files I have left alone because I want to run this off MySQL

    Any help would be awesome
  10. Offline


    LWC will not do and create the same error as other important plugins
  11. Offline


    This should work. Do they have access to the given permissions? have you checked to see if Guest can build or not (I'm assuming they aren't supposed to) I would check for errors with the Online YAML Parser
  12. Offline


    Thanks for that I am now just wondering where to put the track's For the promote /demote I have to make 2 tracks because i need 1 for my mods and 1 for my admins :D

    Global or in the worlds them self

    Fyi i had fun removing permissions from my nether world such as flying and /home :D

    ok small issue I am Owner in the globalusers then i join my main world and it shows me as the default group because i am not in that worlds users.yml but i still have all the permissions of owner :/

    How is the file meant to inherit the global groups wasnt it some thing like

    - *Mod

    or some thing like that can some 1 tell me please

    You need another plugin for that like commandbook or defaultcommands

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  13. Offline


    I get with Bukkit 860 this, when a new player joins:

  14. Offline


    To start with, you need to put in the tables and so, in the database your self.
    Read this page on how to do that: Link

    I would like to know too, how to get this to work with MySQL..
    I have the exact same information in my files, though with my own mysql databse name, user and password.

    Some info about how to set this up with MySQL would be awesome..
    And yes i HAVE imported all the SQL data from the wiki, and read the wiki page several times, to see if there were something i had missed.. But without luck.. And honestly, i don't wanna look through 100+ pages just to see if one person or two might have posted a little about how to do this :p

    Whenever i try to add a new person or group to permissions, the new user/group is just being added to my default world (world) YAML file, but that can't be right can it??
  15. Offline


    Any guide here how to START with mysql complete (I have to create me in mysql manually, how?!)
  16. Offline


    Why would this allow me access to the give etc commands?

            default: false
                prefix: ''
                suffix: ''
                build: true
            - '*'
            - -essentials.give
            - -essentials.item
  17. Offline


    Because you have the - '*' under permissions for your default group :)
    Remove that line, and the Default group will only have access to the two other things.
  18. Offline


    U just failed He has removed access to the 2 give commands how he has it should nove give him the command

    his file gives every thing then removes give and item.....

    Except if he is an Op minecraft has a /give command built in is it your op command that is the issue.

    You are wrong About the node if i was to add it to a group there and say leave it out of another file it would have 0 effect because what is happening to me is all my global permissions work but all the info in the such as prefix and suffix that are set in the world's group file take no effect because i am not in that worlds users file. I am only in the Global users file. I should not have to add my self to all 3 users file (2 worlds and the global)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  19. Offline


    My bad :p
    Didn't see the "-" before essentials.give.
  20. Plugin work perfectly, but I have a problem. I use permissions SQL
    I want define the Defaultgroup but it's don't work :( .

    PrWorld Base :

    name : Default
    type : 1


  21. Offline


    In the API how do you effect globalUsers.yml file? What world do you specify to add/remove someone from a group there?
  22. Offline


    I keep getting this on startup/reload:

    2011-06-18 11:56:04 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.permissions.ModularControl
    2011-06-18 11:56:04 [SEVERE]    at com.nijiko.permissions.ModularControl.<clinit>(
    2011-06-18 11:56:04 [SEVERE]    at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-06-18 11:56:04 [SEVERE]    at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-06-18 11:56:04 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-06-18 11:56:04 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.reload(
    2011-06-18 11:56:04 [SEVERE]    at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
    2011-06-18 11:56:04 [SEVERE]    at org.bukkit.command.SimpleCommandMap.dispatch(
    2011-06-18 11:56:04 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    2011-06-18 11:56:04 [SEVERE]    at net.minecraft.server.MinecraftServer.b(
    2011-06-18 11:56:04 [SEVERE]    at net.minecraft.server.MinecraftServer.h(
    2011-06-18 11:56:04 [SEVERE]    at
    2011-06-18 11:56:04 [SEVERE]    at
    2011-06-18 11:56:04 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-18 11:56:04 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    2011-06-18 11:56:04 [INFO] [Permissions] (Yeti) was initialized.
    It's confusing since other plugins detect Permissions although it's not loading properly.. I think it affects the functionality of other plugins, like WorldGuard, as well.
  23. Offline


    Permissions is working because of the build true false, not essentials, ask over there as your files are sound so it's not an error on this end, more so on theirs

    Global is *

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  24. Offline


    Uh i cant make this do what i want my files are fine its just finding the right setup to do what i want.

    Heres what i want from this plugin.

    1 synced users list for my 2 maps 1 master set of permissions (global) and some adjustments to permissions on a per world level. i also want My prefix and suffix from the global file to effect all worlds as of now it dose not seem to have any effect.

    my problem atm lies in that the world controls my final Display group I have owner status in global but in the world file i am a noob because i am not in its users.... so i am an owner that looks like a noob.... Just fail the group names are the same for global as the map yet i cant seem to get my global users file to carry to all the worlds and display the right prefixes ect here are all my files i have 2 maps normal and nether what the hell am i doing wrong :/

    Global and

    Can some 1 please help me under stand how to get my groups set up to do what i want :/

    Attached Files:

  25. Offline


    I Posted 2 days ok so dont act bossy, mkay?
    and it IS important cuz its unnecesary work for my staff to promote EVERY player again. mkay?

    So how can i fix the wipe of user.yml of the world folder? it happens randomly if someones joins.
  26. Offline


    Got this (below) spammed into the console after about an hour of running the server, restarted the server and it occured again in roughly the same time period.

    14:18:59 [SEVERE] Caused by: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    The last packet successfully received from the server was 411,406 milliseconds ago.  The last packet sent successfully to the server was 0 milliseconds ago.
    14:18:59 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    14:18:59 [SEVERE]       at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    14:18:59 [SEVERE]       at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    14:18:59 [SEVERE]       at java.lang.reflect.Constructor.newInstance(
    14:18:59 [SEVERE]       at com.mysql.jdbc.Util.handleNewInstance(
    14:18:59 [SEVERE]       at com.mysql.jdbc.SQLError.createCommunicationsException(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.sendCommand(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    14:18:59 [SEVERE]       at com.mysql.jdbc.ConnectionImpl.execSQL(
    14:18:59 [SEVERE]       at com.mysql.jdbc.PreparedStatement.executeInternal(
    14:18:59 [SEVERE]       at com.mysql.jdbc.PreparedStatement.execute(
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at com.nijiko.permissions.Entry.getPermissions(
    14:18:59 [SEVERE]       at com.nijiko.permissions.Entry.has(
    14:18:59 [SEVERE]       at com.nijiko.permissions.Entry.hasPermission(
    14:18:59 [SEVERE]       at com.nijiko.permissions.ModularControl.permission(
    14:18:59 [SEVERE]       at com.nijiko.permissions.ModularControl.permission(
    14:18:59 [SEVERE]       at com.nijiko.permissions.ModularControl.has(
    14:18:59 [SEVERE]       at com.sk89q.bukkit.migration.NijiPermissionsResolver.hasPermission(
    14:18:59 [SEVERE]       at com.sk89q.bukkit.migration.PermissionsResolverManager.hasPermission(
    14:18:59 [SEVERE]       at com.sk89q.worldguard.bukkit.WorldGuardPlugin.hasPermission(
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at
    14:18:59 [SEVERE]       at com.sk89q.worldguard.bukkit.WorldGuardBlockListener.onBlockBreak(
    14:18:59 [SEVERE]       ... 13 more
    14:18:59 [SEVERE] Caused by: Can not read response from server. Expected to read 4 bytes, read 0 bytes before connection was unexpectedly lost.
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.readFully(
    14:18:59 [SEVERE]       at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    14:18:59 [SEVERE]       ... 39 more
    Also, I can't work out for the life of me how you actually set a 'default' group - Users seem to get the 'info' from the Default group, but none of the permissions until I manually set their parent.
  27. Offline


    I installed permissions to edit permission nodes, but it didn't work. Every time I loggede into my server, it accused me of hacking and kicked me out. I have a LEGIT minecraft account, so I don't know why it happened. So, I delete the permissions.jar and the permissions folder in my plugins folder, and itworked. but now, I want to use Groupmanager instead for editing permission nodes, but when i type anything in notepad ++ it turns red... I launch me server, and it says that Permissions plugin is still being detected! I deleted the permissions plugin, so I don't know why it was doing that. I ended up de;eting my ENTIRE craftbukkit folder, and Re-installed everything. I DID NOT install permissions. I launch my server, and IT IS STILL BEING DETECTED!!!!!!!! :mad: HELP??
  28. hey, i'm really sorry but I can't for the love of god work out the Promote and Demote commands work in game. It keeps saying that specified User isn't in that Group. Can anyone help or point me at something that explains how it works?
  29. Offline


    Sometimes permissions stop working with this error:
    Bukkit 860, permissions 3.1.5 with the sql connector.
  30. Offline


    Could this entire thing be any more arcane to figure out? I can't actually find any plain english in how to setup basic things like stopping people from destroying blocks or using certain mods. About the only thing that has happened is I cant place any blocks on my server and cant find any guide as to how to use this thing properly.
  31. Offline


    Build: true/false = Allow or Deny Block Placement and Destruction per group per world
    Plugins that use permissions will give you their permission nodes in their own topics, how to use them can be easily figured out purely from the example files
    If you did not mean plugins but actual mods such as GunMod then you are barking up the wrong tree, Mods can not be allowed or denied by permissions as they run within the server, not bukkit
    As for a guide on how to use it, did you consider the Wiki or posting your questions in this topic where someone will eventually give you an answer?
Thread Status:
Not open for further replies.

Share This Page