Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    rcjrrjcr

    Permissions 3.1.6 (Yeti)

    Download:
    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions


    COMMAND RESTRUCTURING
    Feel free to comment and give suggestions.


    DO NOT USE GLOBAL CONFIGS FOR NOW. THE GLOBAL CONFIG IS MEANT TO SUPPLEMENT WORLD-SPECIFIC CONFIGS, NOT THE OTHER WAY ROUND. SEE https://github.com/TheYeti/Permissions/wiki/Global-vs-World .I WILL WRITE A PROPER TUTORIAL ON HOW TO USE THE GLOBAL CONFIGS SOON.

    TODO:
    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)




    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.





    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x







    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​


    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:


    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from server.properties is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.


    FAQ (open)

    [FAQ]

    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in server.properties at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.


    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.



    Changelog
    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)





    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems








    Credits (open)


    TheYeti:
    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    rcjrrjcr:
    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​


    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
     
  2. Offline

    Hipachi

    I need help with my permissions, basically I want to add colour and group tag so its like <Admin><Hipachi><Message>. But it doesn't seem to work. I use to with old permissions :p But now my name just comes up as Hipachi. I have two permissions folders. One with my worlds name and one named permissions. Inside my world folder I have a groups.yml and users.yml Groups file looks like groups:
    Code:
    Groups Folder
    Default:
    default: true
    info:
    prefix: '&7'
    suffix: '[&7Default]'
    build: false
    inheritance:
    permissions:
    - 'foo.bar'
    - 'mcmmo.ability.woodcutting'
    - 'mcmmo.ability.mining'
    - 'mcmmo.ability.axes'
    - 'mcmmo.ability.excavation'
    - 'mcmmo.ability.swords'
    - 'mcmmo.ability.unarmed'
    - 'mcmmo.ability.herbalism'
    - 'mcmmo.skills.*'
    - 'mcmmo.regeneration'
    - 'mcmmo.chat.partychat'
    - 'mcmmo.commands.ability'
    - 'mcmmo.commands.ptp'
    - 'mcmmo.commands.party'
    - 'mcmmo.commands.whois'
    - 'mcmmo.commands.myspawn'
    - 'mcmmo.commands.setmyspawn'
    - 'mcmmo.commands.setmyspawnother'
    - 'backtobody.btb'
    - 'essentials.help'
    - 'essentials.getpos'
    - 'essentials.sethome'
    - 'essentials.home'
    - 'essentials.msg'
    - 'essentials.ms'
    - 'essentials.afk'
    - 'essentials.motd'
    - 'essentials.rules'
    - 'essentials.me'
    - 'essentials.list'
    - 'essentials.mail'
    - 'essentials.mail.send'
    - 'essentials.helpop'
    - 'essentials.whois'
    - 'essentials.nick'
    - 'essentials.clearinventory'
    Moderator:
    default: false
    info:
    prefix: '&9'
    suffix: '[&9Moderator]'
    build: true
    inheritance:
    - Default
    permissions:
    - 'bar.foo'
    - 'worldguard.god'
    - 'worldguard.fire-toggle.stop'
    - 'worldguard.fire-toggle.stop'
    - 'worldguard.heal'
    - 'worldguard.slay'
    - 'worldguard.heal.other'
    - 'worldguard.slay.other'
    - 'worldguard.stack'
    - 'worldguard.locate'
    - 'worldguard.locate'
    - 'worldguard.locate'
    - 'guestprev.advanced.add'
    - 'guestprev.advanced.remove'
    - 'essentials.weather'
    - 'essentials.thunder'
    - 'essentials.lightning'
    - 'essentials.suicide'
    - 'essentials.heal'
    - 'essentials.heal.others'
    - 'essentials.heal.cooldown.bypass'
    - 'essentials.god'
    - 'essentials.tree'
    - 'essentials.bigtree'
    - 'essentials.time'
    - 'essentials.invsee'
    - 'essentials.kick'
    - 'essentials.kickall'
    - 'essentials.unbanip'
    - 'essentials.unban'
    - 'essentials.mute'
    - 'essentials.banip'
    - 'essentials.tempban'
    - 'essentials.ban'
    - 'essentials.kill'
    - 'essentials.broadcast'
    - 'essentials.burn'
    - 'essentials.ext'
    - 'essentials.clearinventory'
    - 'essentials.clearinventory.others'
    - 'essentials.seen'
    - 'essentials.warp.[warpname]'
    - 'essentials.setwarp'
    - 'essentials.delwarp'
    - 'essentials.home.others'
    - 'essentials.tppos'
    - 'essentials.tpall'
    - 'essentials.tpahere'
    - 'essentials.tphere'
    - 'essentials.tpohere'
    - 'essentials.tp'
    - 'essentials.tpo'
    - 'essentials.tpa'
    - 'essentials.back'
    - 'essentials.jump'
    - 'essentials.top'
    - 'essentials.compass'
    - 'essentials.togglejail'
    - 'essentials.jail.exempt'
    Admin:
    default: false
    info:
    prefix: '&c'
    suffix: '[&cAdmin]'
    build: true
    inheritance:
    permissions:
    - '*'
    
    USERS FILE
    users:
        TheNo1Yeti:
            groups:
                - Admins
            permissions:
        Herpina:
            groups:
                - Moderator
            permissions:
                - 'herp.derp'
        Derpina:
            groups:
                - Admins
            info:
                prefix: '&c'
            permissions:
                - '-derp.derp'
        Hipachi:
            groups:
                - Admin
            info:
                prefix: '&c'
            permissions:
                - '*'

    If need my permissions with the globalGroups,yml,globalUsers.yml,storageconfig.yml and another world file with my groups.yml and users.yml. Thanks and sorry for being a bit of a nub XD
     
  3. Offline

    toongos

    Сould anyone help me to fix a little problem with "You don't have permission to use this" message? I've got it anytime when I build any block. And when I destroy any block the message is absent. What should I do to fix it?
     

    Attached Files:

  4. Offline

    rafalon

    A have a little problem here:
    Code:
    11:51:40 [SEVERE] while scanning for the next token
    found character         '\t' that cannot start any token
     in "<reader>", line 6, column 1:
    
        ^
    
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:3
    60)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:183)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(P
    arserImpl.java:200)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:163)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:104)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstruc
    tor.java:124)
    11:51:40 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(Yaml.java:264)
    11:51:40 [SEVERE]       at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfiguration.j
    ava:54)
    11:51:40 [SEVERE]       at com.nijiko.data.YamlUserStorage.<init>(YamlUserStorage.java:31)
    11:51:40 [SEVERE]       at com.nijiko.data.YamlCreator.getUserStorage(YamlCreator.java:34)
    11:51:40 [SEVERE]       at com.nijiko.data.StorageFactory.getUserStorage(StorageFactory.java:76)
    11:51:40 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(ModularControl.java:
    92)
    11:51:40 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(ModularControl.java:84)
    11:51:40 [SEVERE]       at com.nijiko.permissions.ModularControl.load(ModularControl.java:104)
    11:51:40 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(Permissions
    .java:186)
    11:51:40 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(Permissions.java:139)
    
    11:51:40 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:106)
    11:51:40 [SEVERE]       at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    11:51:40 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    11:51:40 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    11:51:40 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:285)
    11:51:40 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    11:51:40 [SEVERE] [Permissions] Unable to load permission data.
    11:51:40 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    11:51:40 [INFO] [Permissions] (Yeti) was initialized.
    How I can fix this?
     
  5. Offline

    Brianbloke


    Sorry, I had to go as it was 1am in the UK.
    Thanks very much, I'll PM you as soon as the server has all plugins, and the server is completed made, to invite you to the server. I found it in the storage.yml file.

    I've fixed it now, but when I go ingame, it keeps showing up when I type that I'm a "Guest" when I'm really the owner, of which thats even stated in the .yml
     
  6. Offline

    AegisZephyr

    I am having an odd issue and not sure if this has been addressed but after trying to sort through a few pages of bickering was still not able to find anyone that had a similar issue. I recently updated our server from permissions 3.1.4 to 3.1.5b. All was going well until the server had its scheduled restart. Then every plugin decided to spit out errors and not start and all hell broke loose. Oddly, renaming the permissions folder to permissionsbackup, using /reload and letting it create its new directory, then deleting the new permissions folder, and renaming permissions backup back to permissions and just reloading permissions allowed everything to work fine once more. Is anyone else having this issue? I also updated to the new RB #860 and everything seemed to go fine until the restart. I have also tested all the permissions with that online YAML parser to make sure there were no errors but upon server restart or reload with the permissions folder the way it is seems like it somehow breaks itself with no errors until I perform the procedure above.

    To recap my procedure
    1. Server start with desired permissions->all plugins break and refuse to work
    2. rename permissions folder to permissionsbackup
    3. /reload
    4. delete new permissions folder and rename permissionsbackup back to permissions
    5. /pr -reload all
    6. Everything working fine
    7. Server scheduled restart->return to 1
     
  7. Offline

    Maxis010

    Sorry if this has already been answered, can't be asked to check 4 pages for a reply when it was missed on this page
    You need a closing ' n the end of movecraft.*
     
  8. Offline

    racecar56

    Cool picture name.
     
  9. Offline

    Hipachi

    I've got ichat but doesn't seem to work :p Can help me

    I had this problem, seems you have made a error in your spelling somewhere. It says /t so I would look for that!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  10. Offline

    Maxis010

    Get Notepad++, use it to convert your tabs to 4 spaces, the /t token is a tab
    See above, it has nothing to do with spelling
     
  11. Offline

    roughnecks21

    Ok im probably having a freak problem but i made sure everything was spaced properly i did everything i was told to do and my permissions just dont work on my server, it doesnt allow me to use mywarp and even though i have iconomy.payment on as a node it still doesnt allow users to us it. here is my code for groups
    Code:
    ##
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    ##
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #
    #   Example:
    #       inheritance:
    #           - Default
    ##
    #   Globalized Permission settings:
    #
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #
    #           - 'foo.*'
    #
    #       This will allow you to use all general commands.
    #
    ##
    #   Single Asterisk denotes all commands:
    #
    #       - '*'
    ##
    #   To exempt a node use the - prefix like so:
    #       - '-foo.bar'
    ##
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
    groups:
        Amatsu:
            default: true
            info:
                prefix: '&1'
                suffix: ''
                build: true
            inheritance:
            permissions:
                - 'iConomyChestShop.shop.create'
                - 'iConomyChestShop.shop.buy'
                - 'iConomyChestShop.shop.sell'
                - 'iConomyChestShop.command.iteminfo'
                - 'iConomy.access'
                - 'iConomy.payment'
                - 'iConomy.list'
                - 'iConomy.rank'
        Jaaku:
            default: true
            info:
                prefix: ''
                suffix: ''
                build: true
            inheritance:
                - Amatsu
            permissions:
        Admins:
            default: false
            info:
                prefix: '&4'
                suffix: ''
                build: true
            inheritance:
            permissions:
                - '*'
    and my users
    Code:
    ##
    # Users denote which users are included in which group.
    # TheNo1Yeti is in the Admin group
    # Herpina is a member of the Moderator group but also has access
    # to the herp.derp permissions
    # Derpina is a member of the admin group but does not have access
    # to the derp.derp permission node
    # Users can have a prefix and suffix of their own.
    ##
    users:
        roughnecks21:
            groups:
                - Admins
            permissions:
    Please i need help with this. It boggles my mind on why it is not working.
    If you need a list of my plugins here it is
    BigBrother
    ClothColor
    iConomy
    iConomyChestShop
    LWC
    MyWarp
    NoCheat
    Residence
    uQuest
    Weathergod
    Worldedit
    Worldgaurd
     
  12. Offline

    Vhab

    My post seems to get buried between the huge stream of posts with just yaml syntax errors.
    Going to try this again, anyone with in-depth knowledge of Permissions 3 knows what's going on here?
    Seems to me this is either a bug in Permissions 3 or really unintuitive behavior.

     
  13. Offline

    Hipachi

    Permissions 2x use to work great but now permissions 3x has had alot of problems :/ I would just wait!

    I got a website that should help solve problems ;D http://www.wi-alliance.com/yamlhelper/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 9, 2018
  14. Offline

    po5

    Allright thank you Jeyge sounds like what i need


    Hmm, i have a request regarding the anti-build. Do you think you can make it stricter? I dont like people being able to open doors, chests etc. Like, i want the anti-build to be anti-actions. All you can do as a blacklisted/non-builder is walk around and look. No interactions :)
     
  15. Offline

    Vhab

    That doesn't particularly help me at the moment.
    The globalUsers and globalGroups feature is why I'd want to use Permissions 3.
    I prefer try to find out what exactly is going wrong and communicate my issues to the authors rather than just sit around and wait for a new release.
    For all I know they're not aware of this particular issue, or I'm using Permissions 3 wrong and this behavior is working as intended.
     
  16. Offline

    Maxis010

    Get GuestPrev, it can use your build settings to authorise people, all you have to do is deny them everything in the config (use the generated one, not the zipped one as I had trouble with the zipped for an unknown reason)
     
  17. Offline

    rafalon

    Thanks Man! :D
     
  18. Offline

    15austin

    Permissions keeps on disabling itself
    Group.yml and users.yml attached to post

    I get this message on the console
    "
    [INFO] [Permissions] (Yeti) disabled succesfully.
    "
    What is wrong?
     

    Attached Files:

  19. Offline

    Pim1234

    here are my errors:

    when placing a block:

    Code:
    15:57:45 [SEVERE] java.lang.NullPointerException
    15:57:45 [SEVERE]     at com.sk89q.bukkit.migration.NijiPermissionsResolver.hasPermission(NijiPermissionsResolver.java:61)
    15:57:45 [SEVERE]     at com.sk89q.bukkit.migration.PermissionsResolverManager.hasPermission(PermissionsResolverManager.java:102)
    15:57:45 [SEVERE]     at com.sk89q.craftbook.bukkit.BaseBukkitPlugin.hasPermission(BaseBukkitPlugin.java:180)
    15:57:45 [SEVERE]     at com.sk89q.craftbook.bukkit.BukkitPlayer.hasPermission(BukkitPlayer.java:52)
    15:57:45 [SEVERE]     at com.sk89q.craftbook.mech.Cauldron.onRightClick(Cauldron.java:99)
    15:57:45 [SEVERE]     at com.sk89q.craftbook.MechanicManager.dispatchBlockRightClick(MechanicManager.java:168)
    15:57:45 [SEVERE]     at com.sk89q.craftbook.bukkit.MechanicListenerAdapter$MechanicPlayerListener.onPlayerInteract(MechanicListenerAdapter.java:103)
    15:57:45 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader$10.execute(JavaPluginLoader.java:306)
    15:57:45 [SEVERE]     at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    15:57:45 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    15:57:45 [SEVERE]     at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:166)
    15:57:45 [SEVERE]     at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:212)
    15:57:45 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:550)
    15:57:45 [SEVERE]     at net.minecraft.server.Packet15Place.a(SourceFile:57)
    15:57:45 [SEVERE]     at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    15:57:45 [SEVERE]     at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    15:57:45 [SEVERE]     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    15:57:45 [SEVERE]     at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    15:57:45 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    15:57:45 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    
    when starting up:
    Code:
    15:53:33 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.permissions.ModularControl
    15:53:33 [SEVERE]     at com.nijiko.permissions.ModularControl.<clinit>(ModularControl.java:45)
    15:53:33 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(Permissions.java:184)
    15:53:33 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(Permissions.java:139)
    15:53:33 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:112)
    15:53:33 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    15:53:33 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    15:53:33 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    15:53:33 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    15:53:33 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    15:53:33 [SEVERE] [Permissions] Unable to load permission data.
    15:53:33 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    15:53:33 [INFO] [Permissions] (Yeti) was initialized.
    
     
  20. Offline

    Haduke

    After spending several hours this morning trying to get this to work properly, I have finally decided to give up. To be perfectly honest, Permissions sounds WAY over the top in my opinion. If I find a plugin that I am interested in that relies on permissions to work, then I guess I just won't be using said plugin.
     
  21. Offline

    bluemoondevil

    I keep getting this error.

    09:12:01 [SEVERE] java.lang.NoSuchMethodError: com.nijiko.permissions.Permission
    Handler.inGroup(Ljava/lang/String;Ljava/lang/String;)Z
    09:12:01 [SEVERE] at com.sk89q.bukkit.migration.NijiPermissionsResolver.in
    Group(NijiPermissionsResolver.java:77)
    09:12:01 [SEVERE] at com.sk89q.bukkit.migration.PermissionsResolverManager
    .inGroup(PermissionsResolverManager.java:106)
    09:12:01 [SEVERE] at com.sk89q.worldguard.bukkit.WorldGuardPlugin.inGroup(
    WorldGuardPlugin.java:219)
    09:12:01 [SEVERE] at com.sk89q.worldguard.bukkit.WorldGuardPlayerListener.
    onPlayerJoin(WorldGuardPlayerListener.java:438)
    09:12:01 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(Jav
    aPluginLoader.java:243)
    09:12:01 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    eredListener.java:58)
    09:12:01 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    ePluginManager.java:310)
    09:12:01 [SEVERE] at net.minecraft.server.ServerConfigurationManager.c(Ser
    verConfigurationManager.java:126)
    09:12:01 [SEVERE] at net.minecraft.server.NetLoginHandler.b(NetLoginHandle
    r.java:96)
    09:12:01 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandle
    r.java:33)
    09:12:01 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile
    :91)
    09:12:01 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServe
    r.java:399)
    09:12:01 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer
    ver.java:309)
    09:12:01 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour
    ceFile:422)
    09:12:01 [SEVERE] java.lang.NoSuchMethodError: com.nijiko.permissions.Permission
    Handler.inGroup(Ljava/lang/String;Ljava/lang/String;)Z
    09:12:01 [SEVERE] at com.sk89q.bukkit.migration.NijiPermissionsResolver.in
    Group(NijiPermissionsResolver.java:77)
    09:12:01 [SEVERE] at com.sk89q.bukkit.migration.PermissionsResolverManager
    .inGroup(PermissionsResolverManager.java:106)
    09:12:01 [SEVERE] at com.sk89q.worldguard.bukkit.WorldGuardPlugin.inGroup(
    WorldGuardPlugin.java:219)
    09:12:01 [SEVERE] at com.sk89q.worldguard.bukkit.WorldGuardPlayerListener.
    onPlayerJoin(WorldGuardPlayerListener.java:442)
    09:12:01 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(Jav
    aPluginLoader.java:243)
    09:12:01 [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    eredListener.java:58)
    09:12:01 [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    ePluginManager.java:310)
    09:12:01 [SEVERE] at net.minecraft.server.ServerConfigurationManager.c(Ser
    verConfigurationManager.java:126)
    09:12:01 [SEVERE] at net.minecraft.server.NetLoginHandler.b(NetLoginHandle
    r.java:96)
    09:12:01 [SEVERE] at net.minecraft.server.NetLoginHandler.a(NetLoginHandle
    r.java:33)
    09:12:01 [SEVERE] at net.minecraft.server.NetworkListenThread.a(SourceFile
    :91)
    09:12:01 [SEVERE] at net.minecraft.server.MinecraftServer.h(MinecraftServe
    r.java:399)
    09:12:01 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer
    ver.java:309)
    09:12:01 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour
    ceFile:422)
     
  22. Offline

    DoomBunnyPwn

    Thanks so much!
     
  23. Offline

    Ghostetr

    as far as i know its not the permissions plugin there is the problem i think people lack some permissions for craftbook/worlguard. had the same problem once
    rejrrjcr keep up the good work i realy love your plugin :D
    //Ghostetr
     
  24. Offline

    Xordaii

    3.x is still having issues with Global files. Author knows about it, it is being worked on. Until it is fixed, the general advice has been to make your global files, but then to copy them as groups.yml and users.yml for each world, and have a seperate 2 files for each world. Then delete your global files so it recreates them blank. I am sorry it won't help you much because you want the global settings, but that is all we can do atm.

    Speaking of which, @rcjrrjcr could you please update the OP with the information when you do fix that bug? This post is very time consuming to wade through looking to see if you have, and some people (like me!) have a lot of trouble parsing things like forums posts.
     
    Vhab likes this.
  25. Offline

    Nick22

    Is there any way to give a group every command, then take some away
     
  26. Offline

    Vhab

    Thank you. This is really helpful.

    I'll just shelve my current configuration and restore it when the new release is out.
    Our live server is still running on 2.7. They'll just have to wait a bit :)
     
  27. Offline

    Maxis010

    Grant all permissions using '*' then remove permissions with -plugin.node or to mass remove -plugin.*
     
  28. Offline

    Pim1234

    is there a way to solve this??
     
    slyvoo likes this.
  29. Offline

    15austin

    Why is my permissions auto disabling itself?
     
  30. Offline

    Maxis010

    For the first error give yourself craftbook.mech.cauldron (I think that is the node)
    For the 2nd, try redownloading, I doubt it will work but hey
     
  31. Offline

    Dark_Balor

    Just want to know, the version on the git repo is the 2.7.4 not the 3.1.5 ...

    Where can I get the last source code without decompiling it ?
     
Thread Status:
Not open for further replies.

Share This Page