Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    How does permissions compare to essential's group manager in performance impact?
  3. Offline


    I keep getting this on startup of my server:

    148 recipes
    16 achievements
    20:18:46 [INFO] Starting minecraft server version Beta 1.6.6
    20:18:46 [INFO] Loading properties
    20:18:46 [INFO] Starting Minecraft server on *:25565
    20:18:46 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    20:18:46 [INFO] Preparing level "world"
    20:18:47 [INFO] Preparing start region for level 0
    20:18:47 [INFO] Preparing start region for level 1
    20:18:48 [INFO] Preparing spawn area: 4%
    20:18:48 [SEVERE] null; sequence entries are not allowed here initializing Permi
    ssions v3.1.5 (Is it up to date?)
    sequence entries are not allowed here
    in "<reader>", line 105, column 22:
    inheritance: - default

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchBlockEntry(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingValue.produce(P
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    at org.yaml.snakeyaml.composer.Composer.composeNode(
    at org.yaml.snakeyaml.composer.Composer.composeDocument(
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    at org.yaml.snakeyaml.Yaml.load(
    at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfigurati
    at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    20:18:48 [INFO] [Permissions] version [3.1.5] (Yeti) loaded
    20:18:48 [INFO] Done (0.174s)! For help, type "help" or "?"
    20:18:57 [INFO] Brianbloke [/] logged in with entity id 38 at
    (-576.9326061863361, 72.0, 297.3507463341516)
    20:19:15 [INFO] <Brianbloke> sd
    20:19:16 [INFO] <Brianbloke> sad
    >permissions -reload
    20:19:30 [INFO] [Permissions] Permissions was unable to load data during server
    20:19:30 [INFO] [Permissions] Please post the the portion of your server log sin
    ce the server start/reload in the forums thread.

    I'm pretty sure I've done it right, I checked the YAML of it, and there was nothing wrong within the output.
    I've also checked the inheritance line, and it looks fine, I even tried removing the default at one point, but still said the same.
  4. Offline


    You see this ?
    It should look like:
    - default

    But this was in the wiki, too ;-)


  5. Offline


    Just did the full switch, all 20+ plugins working great! Im on CB #848 and perm 3.1.5b
    So far, so good! Got everything working the way it should :)
  6. Offline


    What version of iChat and Permissions do you have? You'll need to post your permissions files to make sure there aren't any problems there.
  7. Offline


    i set everything up on this and nobody can destroy blocks not even admins
  8. Offline


    ok this is making me mad. your commands are way to friggen complicated! i cant even promote users its so bad! syntax error every time no matter what i do. either explain the commands MUCH more clearly or make it so its more like
    /promote <user> <world> <group> [rank]
    the reason rank would be optional is because you need to make it so that groups weights can be easily set. ( not with a complicated command again -.- ) just in the groups.yml make a group be like

    default: true
    prefix: '&b[GUEST]'
    suffix: ''
    rank: 1 <------ that right there is the "weight" of the group
    build: false
    - example.derp

    so rank 1 being the lowest rank 99 being the highest. this is really confusing atm
  9. Offline


    how can i put a member of mine server to enother group?
    eg promote from New to Builder
  10. Offline


    Post your files and we can see if there are any problems. Include a server.log so we can make sure there aren't any errors there.
    Take a look at this post here.

    You'll need to post your files but it looks like you might not have a groups: at the top of your groups.yml file.

    Those are GroupManager commands so it would change the GroupManager files.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Feb 15, 2019
  11. Offline


    i use the newest permissions and the newest ichat
  12. Offline


    There are 3 iChats out there and 2 Permissions. So what did you say those versions were again? Or just post your server.log.
  13. Offline


    22:37:29 [INFO] Starting minecraft server version Beta 1.6.6
    22:37:29 [INFO] Loading properties
    22:37:29 [INFO] Starting Minecraft server on *:25565
    22:37:29 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-766-
    g3fc0460-b818jnks (MC: 1.6.6)
    22:37:29 [INFO] Preparing level "world"
    22:37:29 [INFO] Preparing start region for level 0
    22:37:30 [SCHWERWIEGEND] java.lang.NullPointerException
    22:37:30 [SCHWERWIEGEND]        at<init>(YamlUs
    22:37:30 [SCHWERWIEGEND]        at
    22:37:30 [SCHWERWIEGEND]        at
    22:37:30 [SCHWERWIEGEND]        at com.nijiko.permissions.ModularControl.forceLo
    22:37:30 [SCHWERWIEGEND]        at com.nijiko.permissions.ModularControl.loadWor
    22:37:30 [SCHWERWIEGEND]        at com.nijiko.permissions.ModularControl.load(Mo
    22:37:30 [SCHWERWIEGEND]        at com.nijikokun.bukkit.Permissions.Permissions.
    22:37:30 [SCHWERWIEGEND]        at com.nijikokun.bukkit.Permissions.Permissions.
    22:37:30 [SCHWERWIEGEND]        at org.bukkit.craftbukkit.CraftServer.loadPlugin
    22:37:30 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.e(Minecr
    22:37:30 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.a(Minecr
    22:37:30 [SCHWERWIEGEND]        at net.minecraft.server.MinecraftServer.init(Min
    22:37:30 [SCHWERWIEGEND]        at
    22:37:30 [SCHWERWIEGEND]        at net.minecraft.server.ThreadServerApplication.
    22:37:30 [SCHWERWIEGEND] [Permissions] Unable to load permission data.
    22:37:30 [SCHWERWIEGEND] [Permissions] Shutting down Permissions due to error(s)
    Anybody an idea? My Users and Groups txts are to 100% correct -.-
  14. Offline

    /permissions <target> (w:<world>) promote <parent> (w:<parentworld>) <track>
    /permissions <target> (w:<world>) demote <parent> (w:<parentworld>) <track>
    My permissions files, posted for reference:
    Examples I use:
    This promotes them from Player to the next place on the track (Moderator)
    /pr cembry90 w:world promote Player trackname
    This demotes them from Moderator to the previous place on the track (Player)
    /pr cembry90 w:world demote Moderator trackname
    This makes a new user (Guest group, default) part of the Player group
    /pr newuser w:world promote Guest trackname
    Good luck!
    Don Redhorse likes this.
  15. Offline


    I have a question.

    Whenever you use /manuadd or any of those commands, where does it save those ranks/settings?

    And /manload, what does it exactly do? Because, someone joined my server, I used /manuadd admin, used /manload after it. But after that command, he still couldn't use the commands he should?

    I don't get it. What if I restart my server without /manload, does it still keep the things I didn't put manually in the groups.yml and users.yml?
  16. Offline


    Hi everyone , I've a question.

    How can i disable or use with permisions the commands who are already in bukkit ?
    Because inmy server , anybody can use /ba or anything.

    Thanks in advance :)
  17. Offline


    I'm not aware of a /ba command but if you are talking about the normal OP commands like /item or /give, then you can use DefaultPermissions for that and remove everyone from the ops.txt file.

    You have a tab or multiple tabs on or around line 4 in your groups.yml file. Remove that and all other tabs and you should see the error go away.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  18. Offline


    Hey; I skimmed through the thread rather quickly but not on first blush find anything that would address the issue I am having so hopefully someone might be able to help. I have downloaded and installed Permissions on my server (successfully) and it works just fine with YAML. However when I edit the storageconfig.yml file to use MySQL it does not work. Or rather...the Permissions SQL connector clearly loads properly but when I log in to the server and check things out with the chat commands it is still using the YAML configs. In addition when I check out the tables in my MySQL database nothing has been added.

    The steps I took:
    • Created a database for Permissions in my MySQL server (which I will refer to as mcPermsDB).
    • Created a user for the said (which I will refer to as user).
    • Granted acces to user for SELECT, DELETE, INSERT and UPDATE.
    • Created the tables in the database per the database schema provided on the wiki at Permissions' GIT page.
    • Altered the storageconfig.yml like so:
            type: SQL
            dbms: 'MYSQL'
            uri: 'jdbc:mysql://localhost:3306/mcPermsDB'
            username: 'user'
            password: 'password'
    So for whatever reason; I can't get it to use MySQL instead of the YAML config files. Can anyone help?
  19. Offline


    @rcjrrjcr I'm not sure whether or not someone's said this before or asked this before, but I'll go ahead and post anyway.

    Is it possible to give my "Moderator" players permissions to ban and kick from the server without giving them any other default server commands? Would be very handy as I'm running a no-spawning Survival Server.

    Thanks, and excellent plugin! :)
    - sagethor
  20. Offline


    Done that, even checked the YAML again, and I'm still getting the same problem.
  21. Offline


    You'll need to post your permissions files so we can see what else needs to be changed. Make sure you put it in code tags or on
  22. Offline


    Please make a multilanguage. I definitely want to use a translation into their native language.
  23. Offline


    I get this error on the console, and I'm going to specify what version I'm using:

    Start of Report:

    Build #: 818 (MC 1.6.6)

    Plugin Version: 3.1.5b

    Running these Plugins:
    • WorldEdit
    • WorldGuard
    • Permissions
    Error in Console:
    Show Spoiler

    2011-06-09 19:07:40 [SEVERE] while scanning for the next token
    found character '\t' that cannot start any token
    in "<reader>", line 4, column 1:

    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseFlowMappingValue.produce(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeDocument(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
    2011-06-09 19:07:40 [SEVERE] at org.yaml.snakeyaml.Yaml.load(
    2011-06-09 19:07:40 [SEVERE] at com.nijiko.configuration.NotNullConfiguration.load(
    2011-06-09 19:07:40 [SEVERE] at<init>(
    2011-06-09 19:07:40 [SEVERE] at
    2011-06-09 19:07:40 [SEVERE] at
    2011-06-09 19:07:40 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(
    2011-06-09 19:07:40 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(
    2011-06-09 19:07:40 [SEVERE] at com.nijiko.permissions.ModularControl.load(
    2011-06-09 19:07:40 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-06-09 19:07:40 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-06-09 19:07:40 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-06-09 19:07:40 [SEVERE] at net.minecraft.server.MinecraftServer.e(
    2011-06-09 19:07:40 [SEVERE] at net.minecraft.server.MinecraftServer.a(
    2011-06-09 19:07:40 [SEVERE] at net.minecraft.server.MinecraftServer.init(
    2011-06-09 19:07:40 [SEVERE] at
    2011-06-09 19:07:40 [SEVERE] at
    2011-06-09 19:07:40 [SEVERE] [Permissions] Unable to load permission data.
    2011-06-09 19:07:40 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    2011-06-09 19:07:40 [INFO] [Permissions] (Yeti) was initialized.
    2011-06-09 19:07:40 [INFO] [Permissions] (Yeti) disabled successfully.


    As well, Groups:

    Show Spoiler

    default: true
    prefix: '&2'
    suffix: '&f'
    build: false
    default: false
    prefix: '&9'
    suffix: '&f'
    build: true
    - ' '

    default: false
    prefix: '&5'
    suffix: '&f'
    build: true
    - ' '

    default: false
    prefix: '&b'
    suffix: '&f'
    build: true
    - Default
    - 'worldguard.god'
    - 'worldguard.god'
    - 'worldguard.heal'
    - 'worldguard.slay'
    default: false
    prefix: '&4'
    suffix: '&f'
    build: true
    - 'worldguard.god.other'
    - 'worldguard.god.other'
    - 'worldguard.heal.other'
    - 'worldguard.slay.other'
    - 'worldguard.locate'
    - 'worldguard.stack'
    - 'worldguard.region.define'
    - 'worldguard.region.redefine'
    - 'worldguard.region.claim'
    - ''
    - ''
    - 'worldguard.region.list'
    - 'worldguard.region.setparent'
    - 'worldedit.navigation.unstuck'
    - 'worldedit.navigation.descend'
    - 'worldedit.navigation.ceiling'
    - 'worldedit.navigation.thru'
    - 'worldedit.navigation.jumpto'
    - 'worldedit.navigation.up'
    - 'worldedit.superpickaxe'
    - 'worldedit.superpickaxe.area'
    - 'worldedit.superpickaxe.recursive'
    - 'worldedit.superpickaxe'
    - 'worldedit.drain'
    - 'worldedit.fixlava'
    - 'worldedit.fix.water'
    - 'worldedit.extinguish'
    - 'worldedit.butcher'
    - 'worldedit.remove'

    default: false
    prefix: '&4'
    suffix: '&c'
    build: true
    - 'worldguard.region.flag'
    - 'worldguard.region.setpriority'
    - 'worldguard.region.remove'
    - 'worldguard.region.addmember'
    - 'worldguard.region.removemember'
    - 'worldguard.region.removeowner'
    - ''
    - ''
    - 'worldguard.reload'
    - ''
    - 'worldedit.brush.sphere'
    - 'worldedit.brush.cylinder'
    - 'worldedit.brush.clipboard'
    - 'worldedit.brush.smooth'
    - 'worldedit.brush.ex'
    - 'worldedit.chunkinfo'
    - 'worldedit.listchunks'
    - 'worldedit.delchunks'
    - 'worldedit.clipboard.copy'
    - 'worldedit.clipboard.cut'
    - 'worldedit.clipboard.paste'
    - 'worldedit.clipboard.rotate'
    - 'worldedit.clipboard.flip'
    - 'worldedit.clipboard.load'
    - ''
    - 'worldedit.clipboard.clear'
    - 'worldedit.limit'
    - 'worldedit.generation.cylinder'
    - 'worldedit.generation.sphere'
    - 'worldedit.generation.forest'
    - 'worldedit.generation.pumpkins'
    - 'worldedit.history.undo'
    - 'worldedit.history.redo'
    - 'worldedit.navigation.unstuck'
    - 'worldedit.navigation.descend'
    - 'worldedit.navigation.ceiling'
    - 'worldedit.navigation.thru'
    - 'worldedit.navigation.jumpto'
    - 'worldedit.navigation.up'
    - 'worldedit.region.set'
    - 'worldedit.region.replace'
    - 'worldedit.region.overlay'
    - 'worldedit.region.faces'
    - 'worldedit.region.smooth'
    - 'worldedit.region.move'
    - 'worldedit.region.stack'
    - 'worldedit.regen'
    - 'worldedit.scripting.execute'
    - 'worldedit.selection.pos'
    - 'worldedit.selection.hpos'
    - 'worldedit.selection.chunk'
    - 'worldedit.wand'
    - 'worldedit.wand.toggle'
    - 'worldedit.selection.expand'
    - 'worldedit.selection.contract'
    - 'worldedit.selection.shift'
    - 'worldedit.selection.outset'
    - 'worldedit.selection.inset'
    - 'worldedit.selection.size'
    - 'worldedit.analysis.count'
    - 'worldedit.analysis.distr'
    - 'worldedit.snapshots.list'
    - 'worldedit.snapshots.restore'
    - 'worldedit.snapshots.restore'
    - 'worldedit.superpickaxe'
    - 'worldedit.superpickaxe.area'
    - 'worldedit.superpickaxe.recursive'
    - ''
    - 'worldedit.tool.tree'
    - 'worldedit.tool.replacer'
    - ''
    - 'worldedit.superpickaxe'
    - 'worldedit.brush.options.mask'
    - 'worldedit.brush.options.material'
    - 'worldedit.brush.options.size'
    - 'worldedit.fill'
    - 'worldedit.fill.recursive'
    - 'worldedit.drain'
    - 'worldedit.fixlava'
    - 'worldedit.fix.water'
    - 'worldedit.removeabove'
    - 'worldedit.removebelow'
    - 'worldedit.removenear'
    - 'worldedit.replacenear'
    - 'worldedit.snow'
    - 'worldedit.thaw'
    - 'worldedit.extinguish'
    - 'worldedit.butcher'
    - 'worldedit.remove'
    - 'worldedit.reload'


    Show Spoiler


    - Guest
    - Registered
    - Member
    - Moderator
    - Admins
    - Owner
    - ' '


    Okay, thanks!

    EDIT: It's still broken, even if I do 8 spaces alone.

    I'm using Notepad++.

    (I went Edit -> Blank Operations -> TABS to Space)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  24. Offline



    I am nowusing 3.1.5b of Permissions and I am still having a problem where negative permissions do not remove the node. I have copy and pasted my users and groups yml files below into code blocks. The thing I'm specifically looking at is the Admin group section where I give all permissions and then take away 'worldedit.override.bedrock'. That should remove the ability for the worldedit super pickaxe to destroy bedrock. It doesn't. This configuration (altered for the 2.7 configuration style) works perfect. Something in the 3.x series has this broken.

    There are no errors in my server.log file.

    Any ideas?

    -edit- I am listed as a server op in the op.txt file. If I deop myself, the permission is now correctly being removed. Are server ops immune to permission settings?

            - Admins
            permissions: []
            - Admins
            permissions: []
            - Users
            permissions: []
            default: true
                prefix: ''
                suffix: ''
                build: false
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - 'commandbook.who'
                - 'commandbook.motd'
                - 'commandbook.rules'
                - 'commandbook.time.check'
                - ''
                - ''
                - 'commandbook.say'
                - ''
                - 'commandbook.msg'
                - 'commandbook.whereami'
                - 'commandbook.whereami.compass'
                - 'minecartmania.signs.*'
                - '*'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
            default: false
                prefix: 'Admin '
                suffix: ''
                build: true
                - '*'
                - '-worldedit.override.bedrock'
  25. Offline


    What is the new error?
  26. Offline


    It's still the same.

    Can you provide me an edit to the Groups.yml?
  27. Offline


    I can't remove the tab for you because you didn't post the whole file but some have had luck just copying what they posted here back into the file. The tabs aren't actually translated when put in code tags.
  28. Offline


    Oh okay,

    I can put it up on MediaFire for you:

    "<Edit by Moderator: Redacted mediafire url>
    Last edited by a moderator: Sep 9, 2018
  29. Offline


    Last edited by a moderator: Sep 9, 2018
  30. Offline


    Wonderful. Promoting doesn't work even though the track is correct and I'm using the correct command.
  31. Offline


    use nChat
  32. Offline


    Could someone please explain globalpermissions/users to me since there is absolutely nothing on how to use it in the wiki/anywhere :(

    I'm hoping by setting the globals i can leave my world and nether folders completely blank?
    Do I somehow need to setup inheritance from global?

    I'm using CB820 and Mcma server wrapper thing, it interfaces with the global files and does a good job but the permissions from the global files just don't take effect at all in game. If i copy them to the world folder and rename them to just "users" and "groups" it works fine.
Thread Status:
Not open for further replies.

Share This Page