Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Yes PEX has Preffix's and Suffix's and the "*" node. I don't really make tuts for stuff but if you ever need help with something I would help you as much as I can. PEX does have a wiki page setup that can go through basic steps with you. Super perms is just a name for the new built in Bukkit perms. You will be hearing about it a lot when looking for new plugins. But if you want something as close to Perms3 as possible then go with PEX.
  3. Offline


    I don't know if it is fix yet or already ask but I'll ask any ways.
    I found out that permission doesn't work with plugins that has to do with bow and arrow.
    For mcMMO you cant lvl up Archery.
    For LevelCraft you cant lvl up Archery.
  4. Offline


    When I had levelcraft installed with perms it seemed to work fine for me. You sure the perm nodes were set correctly? At any rate, perms is dead now so maybe try switching to Pex or bukkitperms.
  5. Offline


    I'm getting archery perfectly fine on CB 1060 & mcMMO v1.1.11 and Permissions 3.1.5. what versions of everything are you running?
  6. Offline


    I'm at my wits' end. I've been reading the docs and this forum for hours and I've tried every way I can to get this working but it's not:

    I have three worlds. I want the main world's permissions to be inherited by the other two so that we can simply add or turn off a few things for each. At first I tried global groups/users and after that didn't work, and many complaints from web users, I ditched my effort.

    Now I'm trying to use world-inheritance and I've got my storageconfig file setup exactly like the docs state. I've got my groups and everything in my main world, my users as well. But when ever i move to the new worlds, I loose all permissions and it acts like it doesn't know me.

    Manually moving these files to the new worlds works fine. But world-inheritance does not. What needs to go into the groups.yml and users.yml files of the new worlds (the children)? Any other reason why this isn't working?
  7. Offline


    HELP! Can someone PM me if they can help change my permissions 2 to permissions 3? I tried those converters- Didn't work. I'll return the favor with other plugin help!
  8. Offline


    i did and now i only need help to my permissions and it will be Great if you could help me i dont understand the wiki so much but it could be great if you want to help me!
  9. Offline


    Are you using the SQL backend of PEX or just the normal YML files? Also tell me exactly which part of the setup you are stuck at.
  10. Offline


    im using YML and could i maby send you my permissions 3.x files and then you maby could make them so they work with PEX i just wont like all is the same like on permissions 3.x with colors name and stuff i havent startet yet with making the groups

    permissions x.3 is not begin updatet anymore of what i know

    Permissions x.3 is not begin updatet anymore of what i know we are on build 1060 and the this plugin build is on 935

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  11. Offline

    Robert Pendell

    Read timed out bug fixed but it causes my server to be unable to reload plugins or shutdown at all. I have to force kill the server then start it manually.
  12. Offline


    Then what should we use instead?
  13. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    I've heard good things about PermissionsEx
  14. Offline


    same here

    This plugin needs to be continued idc who does it but I can't even understand Permissions ex

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  15. Offline


    hmm im trying to learn how to use PermissionsEx it's a bit the same like permissions 3.x try it out :D
  16. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    It's unbelievably simple. It sounds to me like you're afraid to change in case you break something. Don't worry, you'll do fine :)
  17. Offline


    Lol, Who cares. Permissions needs to be continued. We don't have to switch at all. Permissions will forever be the best. <3
    Elitedude and rockxz2135 like this.
  18. Offline


    i understand the format if i was maybe doing one world but i run 6-7 worlds

    I fully agree permisisons is too good to just stop. Any plugin dev that takes on this plugin is my hero

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  19. Offline


    There was already a group that tried to revive this plugin but the bukkit staff AND some well respected dev's told them to leave it dead. I fully recommend you guys check out PermissionsEX and use it as your new perms plugin. It is the only thing close to Perm3 that you will find.

    If I had the time, I honestly would. but with school and learning code, I have no other free time. But if you run into smaller issues I could most likely help you.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    More and more plugins are going to stop supporting the outdated system and only use the bukkit team supported/created 'superperms'
  21. Offline


    Then someone better create a guide.
  22. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

    A guide for what? Using a plugin? Those are kinda included in the plugin info.

    A guide for using superperms is easy.

  23. Offline


    A guide on how to set up bukkitpermissions in config
  24. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı

  25. Offline


  26. Offline


    @mbaxter or @RugRats Im confused...what difference does permissionEX offer over this permission system. Both use the same format and both are super-perms compatible. (meaning, I believe, you are able to run bukkitpermissions and permissions at the same time)

    The only think I would say is PermEx is FAR more organized and has SQL support, but is that really worth changing over and rewriting a servers whole permission system...

    In the end you will have to abandon both, no?
  27. Offline


    hmm right now i dont know anything aboute permissionsEX so i dont know where i should start
  28. Offline


    I need an infotool so i can see who placed the block

    Does someone know about what pluggin that does that?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 10, 2018
  29. Big brother, logblock, and hawkeye all come to mind, if I understand what is being asked.
  30. Offline


    Does anyone know why users cant mine diamond or redstone but can mine everything else?
    (except admins with '*')

    I swear ive gone through every plugin and every config file and i cant find it anywhere. You would think it would be a permissions thing in Essentials, itemdrop or world edit/guard, but i cant find it anywhere.

    Plugin's installed


    Figured this is the most generic thread to post in, instead of picing a random plugin.
  31. Offline


    Permissions is using the API created initially by Nijikokun (external API).....

    Superperms API created by the Bukkit Team (Dinnerbone mostly) is the builtin permission system that Bukkit recommends people to use. Superperms is incredibly simple to setup...if you setup Niji's can do this ;).

    I believe that PermissionsEX has the ability to use that is a good thing. I recommend that people only use that aspect of it.

    The above developer is correct...plugins are transitioning to Superperms as we speak...over time plugins that still use the old Permission's API will be phased out and Permission plugins (like this one) will start to die out (just like this one has)

    Face it....Superperms is the future....start getting familiar with it now and make the change.
Thread Status:
Not open for further replies.

Share This Page