Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Yay it works:
    prefix: '&0[&4Evil&0]&2 '
    - Operator

    My next question :p
    How do i make it so that Moderators can promote people but not promote higher then Moderator?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  3. Offline


    I'm having problems setting up permissions. From the tele++ plugin I want all perms but not the jump one cause it messes up feather which I use with voxelAir plugin. So I have it like this.
    - tpp.*
    - -tpp.jump.*
    but doesn't work as expected (?), tried also:
    - 'tpp.*'
    - '-tpp.jump.*'
    with no luck.

    Any help would be greatly appreciated.
  4. Offline


    You should be able to set up a track and give them permissions.promote.<track> but that was broken with 3.1.6 so I would suggest setting your default track to only go to Moderator and giving them permissions.promote. That way they can only promote to Moderator but if you every want to make someone an Admin, you will have to use "parents add"/"parents remove" and/or edit the yml files directly.
    I don't believe you can remove permissions using the wildcards so you would actually have to use "- '-tpp.jump.<foo>'" or just give them:
    tpp.admin.*     #give to admins
    tpp.mod.*       #give to moderators*        #give to all players who you want to tp
    tpp.others.*    #give to all players who you want to tp other players*     #give to all players who you want to tp to worlds
    tpp.request     #give these players the ability to request tp's from those who have the tpp.mod.take permission
    Switch0r likes this.
  5. Offline


    hey, i've been trying to add the /pr <name> promote/demote command to a group (and tried adding it to a user) but i can't get it to work, adding the 'permissions.demote.*' and 'permissions.promote.*' strings still result in the user being told they don't have permissions, giving them the permission 'permissions.*' works but gives too much power, and ideas what could be causing this?
  6. Offline


    hi!, i get an error when launching my server, can anyone see what the problem is??

    21:35:49 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseDocumentSta
    21:35:49 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    21:35:49 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    21:35:49 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    21:35:49 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    21:35:49 [SEVERE] at org.yaml.snakeyaml.Yaml.load(
    21:35:49 [SEVERE] at org.bukkit.util.config.Configuration.load(Configurati
    21:35:49 [SEVERE] at
    21:35:49 [SEVERE] at<init>(YamlGroupStor
    21:35:49 [SEVERE] at
    21:35:49 [SEVERE] at
    21:35:49 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(
    21:35:49 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(Modul
    21:35:49 [SEVERE] at com.nijiko.permissions.ModularControl.load(ModularCon
    21:35:49 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    21:35:49 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    21:35:49 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    21:35:49 [SEVERE] at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    21:35:49 [SEVERE] at net.minecraft.server.ServerConfigurationManager.<init
    21:35:49 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    21:35:49 [SEVERE] at
    21:35:49 [SEVERE] at
    21:35:49 [SEVERE] [Permissions] Unable to load permission data.
    21:35:49 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    21:35:49 [INFO] [Permissions] (Yeti) was initialized.
    21:35:49 [INFO] [Permissions] (Yeti) disabled successfully.
  7. Offline


    The individual permissions of permissions.promote.<track> were broken with the release of 3.1.6 so you will only be able to give permissions.promote and permissions.demote and just make sure your tracks can't promote beyond a level you want your mods/admins to promote to.
    You'll need to post the rest of the error. There should be some information above what you already posted which will say exactly what is broken.
  8. Offline


    Yeah i did found that, thanks for the help.
    Removed Operator from the track and used the nodes permissions.promote and permissions.demote for moderators
    Is there a way so all people can see in chat who gets promoted/demoted ?
  9. Offline



    21:45:59 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-
    g9277096-b953jnks (MC: 1.7.2)
    21:46:00 [SEVERE] expected '<document start>', but found BlockMappingStart
    in "<reader>", line 165, column 2:

    21:46:00 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseDocumentSta
    21:46:00 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    21:46:00 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    21:46:00 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    21:46:00 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    21:46:00 [SEVERE] at org.yaml.snakeyaml.Yaml.load(
    21:46:00 [SEVERE] at org.bukkit.util.config.Configuration.load(Configurati
    21:46:00 [SEVERE] at
    21:46:00 [SEVERE] at<init>(YamlGroupStor
    21:46:00 [SEVERE] at
    21:46:00 [SEVERE] at
    21:46:00 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(
    21:46:00 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(Modul
    21:46:00 [SEVERE] at com.nijiko.permissions.ModularControl.load(ModularCon
    21:46:00 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    21:46:00 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    21:46:00 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    21:46:00 [SEVERE] at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    21:46:00 [SEVERE] at net.minecraft.server.ServerConfigurationManager.<init
    21:46:00 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    21:46:00 [SEVERE] at
    21:46:00 [SEVERE] at
    21:46:00 [SEVERE] [Permissions] Unable to load permission data.
    21:46:00 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    21:46:00 [INFO] [Permissions] (Yeti) was initialized.
    21:46:00 [INFO] [Permissions] (Yeti) disabled successfully.
  10. Offline


    You could use CommandHelper to write a script that would promote a user and send a message but other than that, I'm not aware of a way to do that.
    That would be one error message that I don't have in the FAQ. Could you post your permissions yml files so I can figure out what causes it and update the FAQ? Post them in code tags ({} with a # in the lower right on the toolbar) or on please.
  11. Offline


    ummm, not exacly sure what you mean but here is the group config and user config: = -Groups = Users
  12. Offline


    Your groups: was moved over 4 spaces and your Admins: needed to be moved over 3 more spaces. Give this version a try.
    # Permissions has AntiBuild, which prevents a player from destroying/placing blocks.
    # To prevent a group of players then set the build: flag to false (build: false).
    # If you want a group to be able to build then set it to true.
    # Groups can inherit from other groups.
    #   To make a group inherit the permissions and info nodes from another
    #   group, simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   Wildcard Permission settings:
    #       You can have wildcard nodes which encompass all nodes that match it.
    #       For example, the node "modplugin.*" matches "modplugin.kick", "modplugin.ban",
    #       "modplugin.settings.view", and so on.
    #   A single asterisk means that this user/group has all permissions.
    #       - '*'
    #   Negated nodes are created by prefixing a normal node with "-".
    #   They prevent less specific wildcard nodes from matching the negated node.
    #   For example:
    #   permissions:
    #       - 'foo.*'
    #       - ''
    #   In this case, the user/group will have "", "foo.foobar", and so on, but not "".
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
    #   For more info, visit
            default: false
                prefix: ''
                suffix: ''
                build: false
            default: true
                prefix: '[MEMBER]'
                suffix: '[/]'
                build: true
                - Default
                - 'war.player'
                - 'warpplugin.warp'
                - 'econplugin.basic.*'
                - 'cenotaph.lockette'
                - 'cenotaph.freechest'
                - 'cenotaph.quickloot'
                - 'cenotaph.use'
                - 'cenotaph.freesign'
                - 'cenotaph.sign'
                - 'cenotaph.large'
                - 'turnstile.set.price'
                - ''
                - 'turnstile.make'
                - 'turnstile.earned'
                - 'waypoint.basic.add'
                - 'waypoint.basic.teleport'
                - 'waypoint.home.set_on_bed_leave'
                - 'waypoint.spawn'
                - 'waypoint.warp'
                - 'waypoint.basic.delete'
                - ''
                - ''
                - '<id>'
                - 'choptree.chop'
                - 'OwnBlocksX.use'
                - 'BOSEconomy.common.wallet'
                - 'BOSEconomy.common.income'
                - 'BOSEconomy.common.mastry'
                - ''
                - 'BOSEconomy.common.stats'
                - 'BOSEconomy.common.top5'
                - 'fight.user'
                - 'factions.participate'
                - 'factions.create'
            default: false
                prefix: '[MODERATOR]'
                suffix: '[/]'
                build: true
                - Member
                - 'fight.admin'
                - 'modplugin.ban'
                - 'modplugin.kick'
                - 'modplugin.unban'
                - 'jobs.admin.employ'
                - '<reka daniel>'
                - 'OwnBlocksX.ignoreOwnership'
                - 'BOSEconomy.common.bracket.rename'
                - ''
                - 'BOSEconomy.common.bracket.listmembers'
                - 'BOSEconomy.common.bracket.addmember'
                - 'BOSEconomy.common.bracket.removemember'
                - 'BOSEconomy.common.bracket.setmultiplier'
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - 'BOSEconomy.admin.viewmastry'
                - ''
                - ''
                - ''
                - ''
                - ''
                - 'BOSEconomy.admin.reload'
                - ''
                - 'BOSEconomy.admin.bracket.create'
                - 'BOSEconomy.admin.bracket.remove'
                - 'BOSEconomy.admin.bracket.rename'
                - 'BOSEconomy.admin.bracket.list'
                - ''
                - 'BOSEconomy.admin.bracket.set'
                - 'BOSEconomy.admin.bracket.setmaster'
                - 'BOSEconomy.admin.bracket.removemaster'
                - 'BOSEconomy.admin.bracket.listmembers'
                - 'BOSEconomy.admin.bracket.addmember'
                - 'BOSEconomy.admin.bracket.removemember'
                - 'BOSEconomy.admin.bracket.setmultiplier'
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - 'BOSEconomy.admin.payday.reset'
                - 'SuperSigns.CreateAll'
                - 'SuperSigns.UseAll'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    I've read that some like to use WordPad but I would stay away from it because by default, it wants to save files in the rtf format. But these isn't any reason to not use it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  13. Offline


    nope still don't work i get this error:

    22:25:16 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-
    g9277096-b953jnks (MC: 1.7.2)
    22:25:16 [SEVERE] while scanning a simple key
    in "<reader>", line 116, column 1:
    ' - 'BOSEconomy.common ...
    could not found expected ':'
    in "<reader>", line 171, column 8:

    22:25:16 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleS
    22:25:16 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens
    22:25:16 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    22:25:16 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappin
    22:25:16 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    22:25:16 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    22:25:16 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    22:25:16 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    22:25:16 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeDocument(
    22:25:16 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    22:25:16 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    22:25:16 [SEVERE] at org.yaml.snakeyaml.Yaml.load(
    22:25:16 [SEVERE] at org.bukkit.util.config.Configuration.load(Configurati
    22:25:16 [SEVERE] at
    22:25:16 [SEVERE] at<init>(YamlGroupStor
    22:25:16 [SEVERE] at
    22:25:16 [SEVERE] at
    22:25:16 [SEVERE] at com.nijiko.permissions.ModularControl.forceLoadWorld(
    22:25:16 [SEVERE] at com.nijiko.permissions.ModularControl.loadWorld(Modul
    22:25:16 [SEVERE] at com.nijiko.permissions.ModularControl.load(ModularCon
    22:25:16 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    22:25:16 [SEVERE] at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    22:25:16 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    22:25:16 [SEVERE] at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    22:25:16 [SEVERE] at net.minecraft.server.ServerConfigurationManager.<init
    22:25:16 [SEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe
    22:25:16 [SEVERE] at
    22:25:16 [SEVERE] at
    22:25:16 [SEVERE] [Permissions] Unable to load permission data.
    22:25:16 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    22:25:16 [INFO] [Permissions] (Yeti) was initialized.
    22:25:16 [INFO] [Permissions] (Yeti) disabled successfully.

    yeah, i can see on youtube that there's alot of people using that, i will download it.

    it works fine now :) thank you so much :D:D i've tried so many times to get it working, but i just gave up :p
    anyways works fine now :D and again thank you :D:D:D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 28, 2018
  14. Offline


    Please post your log in code blocks and don't bold it.

    As for the new errors, the first line isn't in either file that you posted so I'm guessing you just added it or you didn't post all of your permissions yml files. The second line is now in column 8 when I had it in column 5. Did you change things?
  15. Offline


    ummm, nope i didn't change anything...

    what do you mena by ''Please post your log in code blocks and don't bold it.'' ???
    i'm norwegian and my english isn't exacly the best:p
  16. Offline


    Bolding stuff like this is bad.
    22:25:16 [INFO] [Permissions] (Yeti) disabled successfully.
    This looks so much better.

    As for your error, it says that Admins: is on line 171 but in the version I posted, it is on line 165. You either have more files in your plugins\permissions directory that have problems or you changed what I posted for you.
  17. Offline


    i use wordpad to open the txt files, does is matter wich program i use for that??
    i only posted the globalgroup config and globaluserconfig..

    :D:D:D:D your code worked when i changed the groups file in bukkit server -> Permissions -> ''my world name'' -> Groups :D
    i only changed the file in Bukkit server -> Permissions -> globalGroups

    i thought i only had to change

    Bukkit server -> Permissions -> globalGroups

    so i think it works now :) i'll let you know if it doesn't :D tnx for the help :D:D

    uhm wich program would you recomend for opening txt files?? ( wich is free) :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 10, 2018
  18. Offline


    I use Notepad++. I've even included some information in the wiki FAQ on how to set it up so you won't have to worry about tabs in your files.
  19. Offline


    151 recipes
    16 achievements
    17:06:13 [INFO] Starting minecraft server version Beta 1.7.3
    17:06:13 [INFO] Loading properties
    17:06:13 [INFO] Starting Minecraft server on *:25565
    17:06:14 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-945-
    g73697a4-b1000jnks (MC: 1.7.3)
    17:06:14 [SEVERE] while scanning for the next token; found character    '\t' tha
    t cannot start any token initializing Permissions v3.1.6 (Is it up to date?)
    while scanning for the next token
    found character         '\t' that cannot start any token
     in "<reader>", line 3, column 1:
                type: YAML
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
            at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingValue.produce(P
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeDocument(
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(
            at org.bukkit.util.config.Configuration.load(
            at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.<init>(
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
            at net.minecraft.server.MinecraftServer.init(
    17:06:14 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    17:06:14 [INFO] Preparing level "world"
    17:06:14 [INFO] Preparing start region for level 0 (Seed: 7033676577497916503)
    17:06:15 [INFO] Preparing spawn area: 85%
    17:06:15 [INFO] Preparing start region for level 1 (Seed: 7033676577497916503)
    17:06:16 [INFO] Preparing spawn area: 97%
    17:06:16 [SEVERE] java.lang.NullPointerException
    17:06:16 [SEVERE]       at com.nijikokun.bukkit.Permissions.PrWorldListener.onWo
    17:06:16 [SEVERE]       at$53.execute(Ja
    17:06:16 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    17:06:16 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    17:06:16 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    17:06:16 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    17:06:16 [SEVERE]       at
    17:06:16 [SEVERE]       at
    17:06:16 [SEVERE] java.lang.NullPointerException
    17:06:16 [SEVERE]       at com.nijikokun.bukkit.Permissions.PrWorldListener.onWo
    17:06:16 [SEVERE]       at$53.execute(Ja
    17:06:16 [SEVERE]       at org.bukkit.plugin.RegisteredListener.callEvent(Regist
    17:06:16 [SEVERE]       at org.bukkit.plugin.SimplePluginManager.callEvent(Simpl
    17:06:16 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServe
    17:06:16 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    17:06:16 [SEVERE]       at
    17:06:16 [SEVERE]       at
    17:06:16 [INFO] Server permissions file permissions.yml is empty, ignoring it
    17:06:16 [INFO] Done (0.220s)! For help, type "help" or "?"
    17:06:20 [INFO] [Permissions] Permissions was unable to load data during server
    17:06:20 [INFO] [Permissions] Please post the the portion of your server log sin
    ce the server start/reload in the forums thread.
    Please help!
  20. Offline


    No need to ever give up as there is almost always someone here to help.
    You have 1 or more tabs in your permissions yml files that need to be removed. YAML doesn't support tabs so you should replace them with r spaces each. Take a look at the wiki FAQ for information on how to remove them with Notepad++ and how to prevent them in the future.
  21. Offline


    I'd use recommend, since it won't insert tabs and does auto-indent. (start -> run -> type "")
  22. Offline


    Aaaand now /money pay doesn't work again. This makes no fucking sense. I haven't touched a god damn thing in since it was working, so why does it suddenly stop working?

    I'm getting pretty effin sick of Permissions 3, it's been nothing but a pain in my ass.
  23. Offline



    jeyge i cant seem to run chunkster ive tried everything on their forums but nothing worked if i post a download for u can you do chunksters for me pls ty

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 2, 2019
  24. Offline


    You seem to have 2 error neither of which have anything to do with Permissions but hopefully this will help.
    2011-08-02 14:59:08 [INFO] [NPC-Quester] uQuest system not enabled. Disabling plugin.
    2011-08-02 14:59:08 [INFO] [NPC-Quester]: Disabled!
    2011-08-02 14:59:08 [INFO] [NPC-Quester]: Permissions detected
    2011-08-02 14:59:08 [SEVERE] Error occurred while enabling NPCQuester v2.2.5 (Is it up to date?): Plugin attempted to register PLAYER_INTERACT_ENTITY while not enabled
    org.bukkit.plugin.IllegalPluginAccessException: Plugin attempted to register PLAYER_INTERACT_ENTITY while not enabled
    is saying that NPC-Quester requires uQuest but you don't have it so it disabled itself. Unfortunately, it still tried to do something after disabling itself. You should report this in their post.
    2011-08-02 15:00:00 [INFO] Chunk file at 45,24 is in the wrong location; relocating. (Expected 45, 24, got 47, 15)
    2011-08-02 15:00:00 [INFO] Chunk (47, 15) stored at  (45, 24)
    is saying that you have some sort of chunk error. You can try running Chunkster to see if it fixes things.
  25. Offline


    How can i give my Moderators the permissions.promote/demote nodes without them able to promote themselves to Admin?

    Any help is appreciated, thanks.

    EDIT: Nevermind, just removed Admins from the track.
  26. Offline


    How do i set the default group when using MYSQL?
  27. Offline


    permissions file for nether in zip

    Attached Files:

  28. Offline


    Seems to be a FAQ today. If you are using 3.1.6, you will have to set up your default track/tracks to not promote to the Admin group. Just remove "- Admin" from the track and they won't be able to promote there. You will then have to use "parents add"/"parents remove" if you want someone in the Admin group.
    See Issue #142 for information on why the default group isn't working with MySQL and a possible way to fix it.
    Those files should be giving you the following error:
    2011-08-02 16:18:04 [SEVERE] while scanning a simple key
     in "<reader>", line 50, column 13:
    could not found expected ':'
     in "<reader>", line 51, column 9:
    and if they aren't, then the files aren't being read at all. If you are getting the error, then add a space after the : and before the true on line 50.
  29. Offline


    I don't have Chunkster on my machine as I run regular backups of my worlds. The one time I had a power failure, a backup had been made just 5 minutes before so we didn't lose anything. You should check out the tutorial if you are having troubles with Chunkster though. I know it has helped most people.
  30. Offline


    well exactly ive watched the videos but none of them worked for me and its now just giving me a big headache
  31. Offline


    You could always start with posting the error you are getting or what isn't working for you.
Thread Status:
Not open for further replies.

Share This Page