Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Yeah ! ->stop ! ->load ! and all errors are missing !! so easy :)
  3. Offline


    In addition to the above i show u my storageconfig;
            type: SQL
            dbms: 'MYSQL'
            uri: 'jdbc:mysql://' # Change Port if Needed
            username: '**********'
            password: '**********'
    (ive tried the above with localhost outside ip etc, and with and without slash behind db name)

    And what i mean about capitals, i created the tables using the sql file, but while in the sql file the tables have names like 'PrData' when ran, the created tables are like 'prdata' and updating the name doesnt fix this.

    Do i maybe need to set a certain (table) engine? (like InnoDB or MyISAM, currentlly theire the first, idk why)
  4. Offline


    You can use parents add/remove to give a specific group. So for you as a Serverowner, you would type:
    /pr Gansta_Hotdog parents remove Serverowner
    /pr Gansta_Hotdog parents add Normal
    but it would be much easier just to demote yourself twice or them once.

    As for them not being able to promote themselves, just don't give them access to the permissions.* permissions. If you only want them to have permissions to promote to the Admin rank, just remove Serverowner from the track. If you only want them to promote to something before Admin, then only give them permissions.promote.<trackthatdoesnotincludeAdmin>. There are many ways to prevent it.
  5. Offline


    But there is always this problem:

    Once a player that connects, even if it is not known to the server and has no permission, the profile is automatically created in:
    plugins -> Permission -> "world" -> user.yml


  6. Offline


    Is there a way to not give them access to that without having to put in all the permissions manually? Cause right now I just have '*'. I guess I can trust my Admins anyway, I just don't want the silly ones to pretend to be the server owner.

    Man, these track things are annoying, why can't it just be simple like Groupmanager was.. "/manuadd playername group" was so bloody simple, it just worked, I mean really, what's the point in these track things anyway? Is there actually any use for them?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  7. Offline


    That is the default behavior of Permissions. Every user that connects to a server or enters a world will be added to the users.yml and given the default group. It was done that way to make it easier to promote them.
    You are meant to trust your Admins. If you don't want them to have those permissions, then add "- '-permissions.*'" to their group.
    GroupManager is still there just waiting to be picked up again.
  8. Offline


    Man, there really needs to be a complete tutorial for this if they wanna make it this complicated. And I mean complete, not just kinda show them the basics and expect them to work the rest out their selves... And easy to understand, too. So people like me don't have to ask questions like this.
  9. Offline


    I was never able to get my test machine to see my MySQL server either so I really can't help you with the connection problems. It does look like the lowercase table names are correct and I wouldn't think one engine over the other would matter.
  10. Offline


    Ah it's new =(

    Thank you again :)
  11. Offline


    But nobody will, because they have Permissions and apparently more complicated and annoying, and breaking quite often= better. :/
  12. Offline


    Um, with the exception of a couple broken builds which were fixed really quickly and a few bugs here and there, Permissions 3.x has had very few problems. It has had a lot of people who have tried to make it do things it wasn't supposed to do. Go back thru all 143 pages of this thread and see how many problems were caused by people trying to only use the global files.
  13. Offline


    Oh, well I was wrong about that bit then. Well thanks for all the help dude, at least until I get around to configuring it properly so Admins can not promote higher than themselves I at least have it so they can't promote at all. You have been really helpful, you deserve a hug for all that :3
  14. Offline


    my server keeps freezing dead at random intervals when I use permissions 3. no error in the log, and I can't soft-restart the server, I have to force end it, causing a rollback to the last save.

    i've reverted to v2 until this is fixed.. can't provide any more info because I don't HAVE any more info.

    this is my plugin list;
    Admin Mode v0.4.3
    Advanced Bans v0.4
    AutoPlant v1.60
    BigBrother v1.9.1
    BlockTowers v0.2
    ButtonWarp v1.0
    Cenotaph v1.5.2
    Command iConomy v7
    CommandBook v1.5.3.57
    CraftBook v3.0.28
    CraftIRC v2.0
    Dynamic Effect Whitelist v0.8
    Dynmap v0.19.1
    FireLord 0.6.1
    GoldenRevive v0.41
    HookShot v1.2.2
    iChat v2.3.1
    iConomy v5.0.1
    Landmarks v0.2
    LightningEvent v1.00
    LocalShops v4.0
    Lottery v0.4.4
    LWC v3.11
    mcMMO v1.0.30
    MobArena v0.92
    MobBounty v4.05
    MobRider v0.39
    ModTRS v1.4.1
    MultiVerse v1.7.2
    Nethrar v2.0
    Netstats v4.7
    NoCheat v1.07b
    Permissions v3.1.6
    properTime v1.8.9
    Showcase v0.6.13
    SignColours v0.3
    SlowHealth v3.2
    Towny v0.71
    WorldEdit v4.7.70
    WorldGuard v5.2.3.96
  15. Offline


    i have been geting nothing but errors on stuff like

    14:14:52 [SEVERE] while parsing a block collection
     in "<reader>", line 2, column 1:
    expected <block end>, but found BlockSequenceStart
     in "<reader>", line 14, column 13:
                    - 'plugin.plug.*'
    Its really starting to piss me off, 3.1.2 was perfect, 3.1.6 killed everything.
    i have remade my entire servers Permissions according to the new Example files included in RENAME-ME
    and its killing me seeing errors spammed T.T
    Is permissions broken? are we waiting on a fix?
  16. Offline

    james wray

    How do i configure it? Because i installed this and now no 1 can build on the server not even ops! i whant so only ops can use worldedit and every1 can build and sethome and stuff please help!
  17. Offline


    How can i disable /pr for non-op... Someone used /pr to add themselves to Admins group.
  18. Offline


    So, in-game commands don't work at all. I'd like to be able to promote people in-game.
  19. Offline


    oh and also i have blaster and i as admin in globalusers
    EDIT: ok its working now thank you for your help
  20. Offline


    So I thought I'd download thsis and try it and here are my errors:
    Show Spoiler
    151 recipes
    16 achievements
    00:31:28 [INFO] Starting minecraft server version Beta 1.7.2
    00:31:28 [INFO] Loading properties
    00:31:28 [INFO] Starting Minecraft server on
    00:31:28 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-
    g9277096-b953jnks (MC: 1.7.2)
    00:31:29 [SEVERE] while scanning for the next token
    found character         '\t' that cannot start any token
     in "<reader>", line 5, column 1:
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreToken
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseIndentlessS
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeSequenceN
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeDocument(
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    00:31:29 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(
    00:31:29 [SEVERE]       at org.bukkit.util.config.Configuration.load(Configurati
    00:31:29 [SEVERE]       at
    00:31:29 [SEVERE]       at<init>(YamlUserStorag
    00:31:29 [SEVERE]       at
    00:31:29 [SEVERE]       at
    00:31:29 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(
    00:31:29 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(Modul
    00:31:29 [SEVERE]       at com.nijiko.permissions.ModularControl.load(ModularCon
    00:31:29 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    00:31:29 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    00:31:29 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    00:31:29 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    00:31:29 [SEVERE]       at net.minecraft.server.ServerConfigurationManager.<init
    00:31:29 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftSe
    00:31:29 [SEVERE]       at
    00:31:29 [SEVERE]       at
    00:31:29 [SEVERE] [Permissions] Unable to load permission data.
    00:31:29 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    00:31:29 [INFO] [Permissions] (Yeti) was initialized.
    00:31:29 [INFO] [Permissions] (Yeti) disabled successfully.
    00:31:29 [INFO] Preparing level "freebuild"
    00:31:29 [INFO] Preparing start region for level 0 (Seed: 7729006755999409273)
    00:31:30 [INFO] Preparing spawn area: 40%
    00:31:30 [INFO] Done (0.172s)! For help, type "help" or "?"

    plugins I have are:
    -permissions v3.1.6
    That is all so don't say "It's probably another plugin"
  21. Offline


    Nope, permissions is working just fine but <GROUPNAME>' isn't a valid group. It should be Default: or something like that. It is also in the wrong column. It should start in column 5. The only thing in column 1 should be groups:, tracks: and track:.

    Post your permissions yml files if you want someone to take a look at them.
    What do your permissions yml files look like? You should be able to give a Moderator group worldedit.* and only include the OPs in that group.
    Just don't give everyone '*' permissions or remove permissions.* by giving them "- '-permissions.*'" if you really want them to have '*'. Post your permissions yml files for more help.
    Post your server.log and permissions yml files and someone will take a look.

    Are you really that worried someone is going to say it is another plugin? I only say that when it is.

    Back to your problem though, it is caused by a tab on line 5, column 1. It needs to be replaced with 4 spaces since YAML files won't work with tabs in them. You'll want to replace all other tabs the same way too.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  22. Offline


    iConomy pointed me here and I installed it to the best of my ability, but it doesn't seem to be doing anything. I get these errors:

    Show Spoiler
    [INFO] Starting minecraft server version Beta 1.7.2
    2011-07-05 00:46:49 [INFO] Loading properties
    2011-07-05 00:46:49 [INFO] Starting Minecraft server on *:25565
    2011-07-05 00:46:49 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    2011-07-05 00:46:50 [INFO] [Permissions] Converting GM/2.x syntax files...
    2011-07-05 00:46:50 [INFO] [Permissions] Conversion complete!
    2011-07-05 00:46:50 [SEVERE] java.lang.Exception: Freshly loaded world object does not exist!
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.ModularControl.safeGetGroup(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.ModularControl.getGrp(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.User.<init>(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.PermissionWorld.reload(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.ModularControl.forceLoadWorld(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.ModularControl.loadWorld(
    2011-07-05 00:46:50 [SEVERE]     at com.nijiko.permissions.ModularControl.load(
    2011-07-05 00:46:50 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(
    2011-07-05 00:46:50 [SEVERE]     at com.nijikokun.bukkit.Permissions.Permissions.onLoad(
    2011-07-05 00:46:50 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-07-05 00:46:50 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.<init>(
    2011-07-05 00:46:50 [SEVERE]     at net.minecraft.server.ServerConfigurationManager.<init>(
    2011-07-05 00:46:50 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-07-05 00:46:50 [SEVERE]     at
    2011-07-05 00:46:50 [SEVERE]     at
    2011-07-05 00:46:50 [INFO] [Permissions] Converting GM/2.x syntax files...
    2011-07-05 00:46:50 [INFO] [Permissions] Conversion complete!
    2011-07-05 00:46:50 [INFO] [Permissions] (Yeti) was initialized.
    2011-07-05 00:46:50 [INFO] [Permissions] version [3.1.6] (Yeti)  loaded
    2011-07-05 00:46:50 [INFO] Preparing level "Wonton"
    2011-07-05 00:46:50 [INFO] Preparing start region for level 0 (Seed: -4480079826893299510)
    2011-07-05 00:46:51 [INFO] Preparing start region for level 1 (Seed: -4480079826893299510)
    2011-07-05 00:46:51 [INFO] Preparing spawn area: 28%
    2011-07-05 00:46:51 [INFO] [Permissions] Converting GM/2.x syntax files...
    2011-07-05 00:46:51 [INFO] [Permissions] Conversion complete!
    2011-07-05 00:46:51 [INFO] Done (0.163s)! For help, type "help" or "?"

    I'm guessing that the "Freshly loaded world object" not existing has something to do with it? I have no idea what that means, though. I'm a complete bukkit virgin.
  23. Offline


    I am getting the exact same error as this fella. The only mod I have atm is permissions. I have checked my YAML and the command is correct.

  24. Offline



    I try to add in prefix but this is the result[​IMG]

    Permissions is so complicated to me, I'm such a noob, please help :)
  25. Offline


    Permissions seems to be thinking it is converting from GroupManager which I'm thinking might be causing the problems. Could you post your permissions yml files so I can play with them a little?
    If you have the same problems as him then the solution should be the same and probably starts with using the wrong command to promote and not having tracks set up. Post your permissions yml files and what command you are trying to do.

    You will need a chat plugin for the prefix and suffix to work. I would suggest either iChat or HeroChat.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
    Gangsta_hotdog likes this.
  26. Offline


    would essentials chat work?
  27. Offline


    what does it mean by column 1, line 5 like in the users or groups thing
  28. Offline


    As long as you don't have any problems with it, it should work.
    The error message doesn't actually say. Sometimes you can tell based on what else in on the line but in this case, the rest of the line is blank. So just look for a line 5 that is blank and has a tab on it or zip up your permissions directory and I'll fix it for you.
  29. Offline


    Thank You for the help i got it alls i did was redo everything.
  30. Offline


    @Jeyge: The video was hard to understand, but this is what I put into my world's groups file:
    Show Spoiler
            default: true
                prefix: '&2'
                suffix: '&f'
                build: false
                - ''
            default: false
                prefix: '&b'
                suffix: '&f'
                build: true
                - Default
                - 'foo.*'
                - '-foo.test'
            default: false
                prefix: '&4'
                suffix: '&f'
                build: true
                - '*'

    And here's what's in my users file:
    Show Spoiler
            - Moderator
            - herp.derp
                prefix: '&b'
            - Default
                prefix: '&4'
            - Admins
            - -derp.derp

    The _nether and global files contain exactly the same thing.

    If it helps, I've never had any other plugins at all, and this is a nearly-untouched map. During the tutorial, when I ran the server to create the .yml files in the empty "shell" folders, it created them but without all the text that he had, so I copied some example code from the Setup Guide link.

    Edit: Forgot this one! Storageconfig.yml
    Show Spoiler
            type: YAML
  31. Offline


    [​IMG] In-Game my players don't have enough permission to create a faction yet I put in the factions.create and everything
    help please :)
Thread Status:
Not open for further replies.

Share This Page