Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Any ETA on when CB928 will get supported? - just curious
  3. Offline


    Thanks this saved the day!
  4. Offline


  5. Offline


    Still didnt work users not working well. Like admin and mod.
    system: default
            - Default

  6. Offline


    I want it working :(
    Permissions (Global Groups)
            default: true
                prefix: ''
                suffix: ''
                build: false
            default: false
                prefix: ''
                suffix: ''
                build: true
            - bookworm.create
            - bookworm.write.own
            - bookworm.copy.own
            - bookworm.copy.others
            - bookworm.remove.own
            - bookworm.destroy.own
            - citizens.use.trader
            - citizens.use.npctype
            - deathcontrol.use
            - heroicdeath.messages
            - heroicdeath.items
            - iConomy.access
            - iConomy.list
            - iConomy.payment
            - uQuest.CanQuest.done
            - uQuest.CanQuest.stats
            - uQuest.CanQuest.give
            default: false
                prefix: ''
                suffix: ''
                build: true
            - Trusted
            - antixray.axr.on
            - weather.invulnerable
            default: false
                prefix: ''
                suffix: ''
                build: true
            - *
            - citizens.admin
            - heroicdeath.messages
            - herospawn.set
            - humiliation.slap
            - humiliation.humiliate
            - humiliation.throw
            - humiliation.leash
            - humiliation.strike
            - humiliation.trap
            - humiliation.admin
            - weather.get
            - weather.set.normal
            - weather.strike.player
            - weather.strike.item
    And the Server log,
    2011-06-25 02:19:18 [SERIOUS] java.lang.IllegalAccessError: tried to access cl
    ass com.nijiko.permissions.ModularControl$RefreshTask from class com.nijiko.perm
    2011-06-25 02:19:18 [SERIOUS] [Permissions] Unable to load permission data.
    2011-06-25 02:19:18 [SERIOUS] [Permissions] Shutting down Permissions due to e
    2011-06-25 02:19:18 [INFO] [Permissions] (Yeti) was initialized.
    2011-06-25 02:19:18 [INFO] [Permissions] (Yeti) disabled successfully.
    Please help me! Many people have tried to solve it but no one has fixed my problem ! :'(
  7. Offline



    default: false
    prefix: ''
    suffix: ''
    build: true
    - '*' <-- added ''
  8. Offline


    Hey guys.

    This morning I tryed to install Permissions 3.
    I was already using a previous version (2.7) but well, didn't even bother trying to upgrade : I just deleted all Permissions stuff and started over.

    So I followed the guide(s). I've put Permissions.jar into my plugin folder, created a Permissions folder in it also, renamed the folder inside the zip with the name of my world, and did the same for nether.

    Then I started the server and looked for the new generated files. They were not generated.

    When I tried to use any command in-game I had a "An internal error occured while attemting to perform this command".

    I'm using the latest Bukkit recommanded (928) and was trying to install Permissions 3.1.5b.

    I made no changes whatsoever to anything, except adding me to the users as an admin.
  9. Offline

    Boon Pek

    Check the last post on the previous page ;P

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  10. Offline


    Other people says that the ' is not good ... :/
  11. Offline


    it will throw parsing errors if you don't, for normal nodes it's fine to leave out the ''
  12. Offline


  13. For some reason after i switched to the latest recommended build of craftbukkit (928) the command /permissions -reload all nolonger works, it just says unknown command. it was working fine before
  14. Offline


    Hey together. I did make a tutorial for Permissions 3.15b in German. If you want me to put it here in just tell me in a comment. Maybe rcjrrcj could stick it in his description of his plugin. (Sry for bad english).
  15. Offline


    Please read the previous page. Commands are broken with permissions 3.1.5b CB911+
  16. Is it possible to deactivate a command from permissions (like if I'm using a plugin like MultiHome that bypasses Essentials but still need Essentials for some other plugins ?)
    Maybe modifying the plugin.yml would work ?

    Edit : Just made it, and while reloading the plugins with Essentials it crashed the server (SO DO IT OFFLINE), finally after rebooting the server, it worked perfectly !

    (Could be added in the FAQ I think)
  17. Offline


  18. Offline


    I must be missing this, but "new" users to the server no longer are being assigned to the "Default" group, thus not allowing them to do anything until I manually add them. Is there a config option I'm missing somewhere to set them as such upon joining?
  19. Offline


    I have been having this problem and no matter what I do I can't fix it. It gives me this message in the console window, and at the same time Permissions is not working in-game. Nobody can build or use commands. It was pointing to the colon and when I removed all the colons the message went away, but the same problems were still happening elsewhere, and I knew that was not right.

    10:50:50 [INFO] 280
    10:50:50 [INFO] 50
    10:50:50 [INFO] [Jail] Loaded 2 jail zones.
    10:50:51 [INFO] [Jail] Loaded 0 prisoners.
    10:50:51 [INFO] [Jail] Loaded 0 cells.
    10:50:51 [INFO] [LoginMessage] 0.6.61 enabled
    10:50:51 [INFO] [LoginMessage] Attempting to fill in local fields...
    10:50:51 [INFO] [LoginMessage] Unable to fill in local fields.
    10:50:51 [INFO] [Permissions] version [3.1.5] (Yeti)  loaded
    10:50:51 [INFO] [iConomy] hooked into Permissions.
    10:50:51 [INFO] TravelPortals version 1.5 is enabled!
    10:50:51 [INFO] [WeatherControl] version 1.2.0 Permissions detected...
    10:50:51 [INFO] [WeatherControl] version 1.2.0 enabled!
    10:50:51 [INFO] Enabled DefaultPermissions v0.3.1
    10:50:51 [INFO] Done (0.258s)! For help, type "help" or "?"
    10:50:51 [INFO] 'spawn-protection' in has been moved to 'setti
    ngs.spawn-radius' in bukkit.yml. I will move your config for you.
    10:52:06 [INFO] sunpak [/] logged in with entity id 30 at ([w
    orld] -23.4375, 83.0, 616.1875)
    10:52:06 [INFO] Creating user sunpak
    10:52:47 [INFO] [bShortcut] version 1.1.0 disabled!
    10:52:47 [INFO] [iConomy] Plugin disabled.
    10:52:47 [INFO] [Permissions] (Yeti) saving data...
    10:52:47 [INFO] [Permissions] (Yeti) saved all data.
    10:52:47 [INFO] [Permissions] (Yeti) disabled successfully.
    10:52:47 [INFO] [WeatherControl] version 1.2.0 disabled!
    10:52:47 [INFO] Disabled DefaultPermissions v0.3.1
    10:52:47 [INFO] [Permissions] (Yeti) was initialized.
    10:52:47 [INFO] BoundaryKill version 1.2 is enabled!
    10:52:47 [INFO] [bShortcut] version 1.1.0 is enabled!
    10:52:48 [INFO] [iConomy] Logging is currently disabled.
    10:52:48 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    10:52:48 [INFO] [iConomy] Developed by: [Nijikokun]
    10:52:48 [INFO] 280
    10:52:48 [INFO] 50
    10:52:48 [INFO] [Jail] Loaded 2 jail zones.
    10:52:48 [INFO] [Jail] Loaded 0 prisoners.
    10:52:48 [INFO] [Jail] Loaded 0 cells.
    10:52:48 [INFO] [LoginMessage] 0.6.61 enabled
    10:52:48 [INFO] [LoginMessage] Attempting to fill in local fields...
    10:52:48 [INFO] [LoginMessage] Unable to fill in local fields.
    10:52:48 [INFO] [Permissions] version [3.1.5] (Yeti)  loaded
    10:52:48 [INFO] [iConomy] hooked into Permissions.
    10:52:48 [INFO] TravelPortals version 1.5 is enabled!
    10:52:48 [INFO] [WeatherControl] version 1.2.0 Permissions detected...
    10:52:48 [INFO] [WeatherControl] version 1.2.0 enabled!
    10:52:48 [INFO] Enabled DefaultPermissions v0.3.1
    10:52:48 [INFO] Reload complete.
    10:52:50 [INFO] sunpak lost connection: disconnect.quitting
    10:52:50 [INFO] Connection reset
    10:52:54 [INFO] sunpak [/] logged in with entity id 65 at ([w
    orld] -23.53125, 84.0, 617.75)
    10:53:45 [INFO] [bShortcut] version 1.1.0 disabled!
    10:53:46 [INFO] [iConomy] Plugin disabled.
    10:53:46 [INFO] [Permissions] (Yeti) saving data...
    10:53:46 [SEVERE] Error occurred while disabling Permissions v3.1.5 (Is it up to
     date?): null; mapping values are not allowed here
    mapping values are not allowed here
     in "<reader>", line 3, column 16:
                default: true
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(
            at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.ja
            at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
            at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(Par
            at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
            at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
            at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
            at org.yaml.snakeyaml.composer.Composer.composeNode(
            at org.yaml.snakeyaml.composer.Composer.composeDocument(
            at org.yaml.snakeyaml.composer.Composer.getSingleNode(
            at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
            at org.yaml.snakeyaml.Yaml.load(
            at com.nijiko.configuration.NotNullConfiguration.load(NotNullConfigurati
            at com.nijiko.permissions.ModularControl.saveAll(
            at com.nijiko.permissions.ModularControl.closeAll(
            at com.nijikokun.bukkit.Permissions.Permissions.onDisable(Permissions.ja
            at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManag
            at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginMana
            at org.bukkit.plugin.SimplePluginManager.clearPlugins(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.reload(
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(SimpleComma
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.h(
    10:53:46 [INFO] [WeatherControl] version 1.2.0 disabled!
    10:53:46 [INFO] Disabled DefaultPermissions v0.3.1
    10:53:46 [SEVERE] mapping values are not allowed here
     in "<reader>", line 3, column 16:
                default: true
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(Sca
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreToken
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappin
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeDocument(
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    10:53:46 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(
    10:53:46 [SEVERE]       at com.nijiko.configuration.NotNullConfiguration.load(No
    10:53:46 [SEVERE]       at
    10:53:46 [SEVERE]       at<init>(YamlGroupStor
    10:53:46 [SEVERE]       at
    10:53:46 [SEVERE]       at
    10:53:46 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(
    10:53:46 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(Modul
    10:53:46 [SEVERE]       at com.nijiko.permissions.ModularControl.load(ModularCon
    10:53:46 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    10:53:46 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    10:53:46 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    10:53:46 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.reload(CraftServer
    10:53:46 [SEVERE]       at org.bukkit.command.SimpleCommandMap$ReloadCommand.exe
    10:53:46 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCo
    10:53:46 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(Cr
    10:53:46 [SEVERE]       at net.minecraft.server.MinecraftServer.b(MinecraftServe
    10:53:46 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServe
    10:53:46 [SEVERE]       at
    10:53:46 [SEVERE]       at
    10:53:46 [SEVERE] [Permissions] Unable to load permission data.
    10:53:46 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    10:53:46 [INFO] [Permissions] (Yeti) was initialized.
    10:53:46 [INFO] BoundaryKill version 1.2 is enabled!
    10:53:46 [INFO] [bShortcut] version 1.1.0 is enabled!
    10:53:46 [INFO] [iConomy] Logging is currently disabled.
    10:53:46 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    10:53:46 [INFO] [iConomy] Developed by: [Nijikokun]
    10:53:46 [INFO] 280
    10:53:46 [INFO] 50
    10:53:46 [INFO] [Jail] Loaded 2 jail zones.
    10:53:46 [INFO] [Jail] Loaded 0 prisoners.
    10:53:46 [INFO] [Jail] Loaded 0 cells.
    10:53:46 [INFO] [LoginMessage] 0.6.61 enabled
    10:53:46 [INFO] [LoginMessage] Attempting to fill in local fields...
    10:53:46 [INFO] [LoginMessage] Unable to fill in local fields.
    10:53:46 [INFO] [Permissions] (Yeti) disabled successfully.
    10:53:46 [INFO] TravelPortals version 1.5 is enabled!
    10:53:46 [INFO] [Permissions] (Yeti) disabled successfully.
    10:53:46 [INFO] [WeatherControl] version 1.2.0 Permissions detected...
    10:53:46 [INFO] [WeatherControl] version 1.2.0 enabled!
    10:53:46 [INFO] Enabled DefaultPermissions v0.3.1
    10:53:46 [INFO] Reload complete.
    10:54:59 [INFO] [bShortcut] version 1.1.0 disabled!
    10:54:59 [INFO] [iConomy] Plugin disabled.
    10:54:59 [INFO] [WeatherControl] version 1.2.0 disabled!
    10:54:59 [INFO] Disabled DefaultPermissions v0.3.1
    10:54:59 [SEVERE] mapping values are not allowed here
     in "<reader>", line 3, column 16:
                default: true
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchValue(Sca
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreToken
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(Sca
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappin
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(Parser
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(Parse
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeMappingNo
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeNode(Comp
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.composeDocument(
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.composer.Composer.getSingleNode(Co
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.constructor.BaseConstructor.getSin
    10:54:59 [SEVERE]       at org.yaml.snakeyaml.Yaml.load(
    10:54:59 [SEVERE]       at com.nijiko.configuration.NotNullConfiguration.load(No
    10:54:59 [SEVERE]       at
    10:54:59 [SEVERE]       at<init>(YamlGroupStor
    10:54:59 [SEVERE]       at
    10:54:59 [SEVERE]       at
    10:54:59 [SEVERE]       at com.nijiko.permissions.ModularControl.forceLoadWorld(
    10:54:59 [SEVERE]       at com.nijiko.permissions.ModularControl.loadWorld(Modul
    10:54:59 [SEVERE]       at com.nijiko.permissions.ModularControl.load(ModularCon
    10:54:59 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    10:54:59 [SEVERE]       at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    10:54:59 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    10:54:59 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.reload(CraftServer
    10:54:59 [SEVERE]       at org.bukkit.command.SimpleCommandMap$ReloadCommand.exe
    10:54:59 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCo
    10:54:59 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(Cr
    10:54:59 [SEVERE]       at net.minecraft.server.MinecraftServer.b(MinecraftServe
    10:54:59 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServe
    10:54:59 [SEVERE]       at
    10:54:59 [SEVERE]       at
    10:54:59 [SEVERE] [Permissions] Unable to load permission data.
    10:54:59 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    10:54:59 [INFO] [Permissions] (Yeti) was initialized.
    10:54:59 [INFO] BoundaryKill version 1.2 is enabled!
    10:54:59 [INFO] [bShortcut] version 1.1.0 is enabled!
    10:54:59 [INFO] [iConomy] Logging is currently disabled.
    10:54:59 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    10:54:59 [INFO] [iConomy] Developed by: [Nijikokun]
    10:54:59 [INFO] 280
    10:54:59 [INFO] 50
    10:54:59 [INFO] [Jail] Loaded 2 jail zones.
    10:54:59 [INFO] [Jail] Loaded 0 prisoners.
    10:54:59 [INFO] [Jail] Loaded 0 cells.
    10:54:59 [INFO] [LoginMessage] 0.6.61 enabled
    10:54:59 [INFO] [LoginMessage] Attempting to fill in local fields...
    10:55:00 [INFO] [LoginMessage] Unable to fill in local fields.
    10:55:00 [INFO] [Permissions] (Yeti) disabled successfully.
    10:55:00 [INFO] TravelPortals version 1.5 is enabled!
    10:55:00 [INFO] [Permissions] (Yeti) disabled successfully.
    10:55:00 [INFO] [WeatherControl] version 1.2.0 Permissions detected...
    10:55:00 [INFO] [WeatherControl] version 1.2.0 enabled!
    10:55:00 [INFO] Enabled DefaultPermissions v0.3.1
    10:55:00 [INFO] Reload complete.
  20. Offline


    I understood everything else but I'm confused on subtracting a permission node, would the code be "-'-permissions. node' " or -'- permissions.node' or '-permissions.node'/-permissions.node' or just flat out 'permissions.node?
    oh and I'm getting another error saying i'm unable to load permissions
    "unable to load permissions"
    "shutting down permissions"
  21. Offline


    I might as well post this here rcjrrjcr replied to my ticket on the github which I have just received.

    He knows about the prefix suffix issues and other stuff it seems and is working on it and says not to use global groups for now.
  22. Offline


    have you tried shoving the groups.yml through a yaml parser to check for any errors? is great.
    EDIT: if your still having issues, you can always post your groups.yml as an attachment or on pastebin or something similar.
  23. Offline


    I got the same thing, even after trying to use permissions plus, it still give's me that error :/
  24. Offline


    same for me, a majority of my plugins arent working
  25. Offline


    All i heard from the Dev Team is that the Bukkit API is only changing the onPlayerMove Event. Not sure how this could affect the commands.
  26. Offline


    If your on 928 CB there are some issues with this still, go to CB 910 for now.
  27. Offline


    I'm still on CB860 actually...
  28. I've upgraded to 3.1.5b and since then I'm having problems with WorldGuard (5) permissions, specifically /region claim, /region setparent, /region add/remove member/owner
    I'm getting "Region Overlaps" error even as admin when I try to do /region claim.
    Everything worked fine until now.
  29. Offline


    These are the errors that I get when I either try to load them, or attempt to activate/use them
    148 recipes
    16 achievements
    09:12:11 [INFO] Starting minecraft server version Beta 1.6.6
    09:12:11 [INFO] Loading properties
    09:12:11 [INFO] Starting Minecraft server on *:25565
    09:12:11 [WARNING] The server will make no attempt to authenticate usernames. Be
    09:12:11 [WARNING] While this makes the game possible to play without internet a
    ccess, it also opens up the ability for hackers to connect with any username the
    y choose.
    09:12:11 [WARNING] To change this, set "online-mode" to "true" in the server.set
    tings file.
    09:12:11 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-889-
    g22f4388-b928jnks (MC: 1.6.6)
    09:12:12 [SEVERE] java.lang.IllegalAccessError: tried to access class com.nijiko
    .permissions.ModularControl$RefreshTask from class com.nijiko.permissions.Modula
    09:12:12 [SEVERE]      at com.nijiko.permissions.ModularControl.<clinit>(Modula
    09:12:12 [SEVERE]      at com.nijikokun.bukkit.Permissions.Permissions.setupPer
    09:12:12 [SEVERE]      at com.nijikokun.bukkit.Permissions.Permissions.onLoad(P
    09:12:12 [SEVERE]      at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    09:12:12 [SEVERE]      at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer
    09:12:12 [SEVERE]      at net.minecraft.server.ServerConfigurationManager.<init
    09:12:12 [SEVERE]      at net.minecraft.server.MinecraftServer.init(MinecraftSe
    09:12:12 [SEVERE]      at
    09:12:12 [SEVERE]      at
    09:12:12 [SEVERE] [Permissions] Unable to load permission data.
    09:12:12 [SEVERE] [Permissions] Shutting down Permissions due to error(s).
    09:12:12 [INFO] [Permissions] (Yeti) was initialized.
    09:12:12 [INFO] Preparing level "world"
    09:12:12 [INFO] Preparing start region for level 0 (Seed: -920269394)
    09:12:13 [INFO] Preparing spawn area: 77%
    09:12:13 [INFO] [MYHOME]: 2 homes loaded
    09:12:13 [INFO] [MYHOME] Permissions enabled using: Permissions v3.1.5
    09:12:13 [WARNING] [MYHOME] 'Help' isn't detected. No /help support.
    09:12:13 [INFO] [MYHOME] MyHome 1.9.5 enabled
    09:12:13 [INFO] [AuthMe] Using flatfile as datasource!
    09:12:13 [INFO] [AuthMe] Cache for registrations is enabled!
    09:12:13 [INFO] [AuthMe] 22 registered players loaded in 0.0080 seconds!
    09:12:13 [INFO] [AuthMe] Version 0.73 is enabled!
    09:12:13 [INFO] BorderGuard version 3.1 is enabled!
    09:12:13 [SEVERE] [ChestLock] Invalid blocktype for khazoids;world;-144;78;-446;
    09:12:13 [SEVERE] [ChestLock] Saving turned off to prevent loss of data
    09:12:13 [INFO] ChestLock 0.9.1 is enabled!
    09:12:13 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [SEVERE] Error occurred while enabling Essentials v2.0.294 (Is it up to
    java.lang.NoSuchFieldError: BLOCK_RIGHTCLICKED
            at com.earth2me.essentials.Essentials.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.init(
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] [MotherNature] Using Permissions version 3.1.5 for permission ha
    09:12:14 [INFO] [MotherNature] Plugin enabled! (version 1.3.2)
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] [OwnBlocks] Database read in from file
    09:12:14 [INFO] [OwnBlocks] version 10.0 initialized
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] [Permissions] (Yeti) disabled successfully.
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] PlgDisableCmd version 1.3 is enabled!
    09:12:14 [INFO] Disabled 4 commands
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] PlgSetspawn version 4.1 is enabled!
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] [RemoveExplosions] Permissions detected, RemoveExplosions hooked
    into permissions
    09:12:14 [INFO] [RemoveExplosions] - Version 1.2 has been enabled.
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] SuperPowers v0.8 loaded!
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] Loaded 53 configs
    09:12:14 [INFO] Loaded 0 shops
    09:12:14 [INFO] [TradeCraft] has recognized Permissions
    09:12:14 [INFO] TradeCraft version AE-1.0.5 is enabled!
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] [Factions v1.3.2] === INIT START ===
    09:12:14 [INFO] [Factions v1.3.2] Loading conf from disk
    09:12:14 [INFO] [Factions v1.3.2] Loading players from disk
    09:12:14 [INFO] [Factions v1.3.2] Loading factions from disk
    09:12:14 [INFO] [Factions v1.3.2] Loading board from disk
    09:12:14 [INFO] [Factions v1.3.2] Found and will use plugin Permissions v3.1.5
    09:12:14 [INFO] [Factions v1.3.2] === INIT DONE (Took 129ms) ===
    09:12:14 [INFO] [ChestLock] Successfully linked with Permissions!
    09:12:14 [INFO] Done (0.246s)! For help, type "help" or "?"
    09:12:14 [INFO] khazoids [/] logged in with entity id 141 at (
    [world] -115.44475527481687, 71.0, -443.3528681587722)
    09:12:14 [SEVERE] Could not pass event PLAYER_JOIN to MotherNature
            at net.minedev.mnplus.MotherNature.MotherNaturePermissions.has(MotherNat
            at net.minedev.mnplus.MotherNature.MotherNaturePermissions.has(MotherNat
            at net.minedev.mnplus.MotherNature.listener.MotherNaturePlayerListener.o
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.ServerConfigurationManager.c(ServerConfiguration
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.Packet1Login.a(SourceFile:43)
            at net.minecraft.server.NetworkManager.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(
    09:12:19 [INFO] Connection reset
    09:12:19 [INFO] khazoids lost connection: disconnect.quitting
    09:12:29 [INFO] Unknown console command. Type "help" for help.
  30. Offline


    For some reason users aren't being assigned the "default" permissions when they login with the latest recommended build.

    Is this something I have done wrong, or is this a problem on your side with the new build?

            default: true
                prefix: ''
                suffix: ''
                build: true
                - ''
                - ''
                - 'essentials.motd'
                - 'essentials.rules'
                - 'arg.user'
                - 'pvptoggle.command.toggle'
                - 'pvptoggle.command.status'
                - 'chaircraft.sit'
            default: false
                prefix: '&b'
                suffix: ''
                build: true
                - Default
                - 'foo.*'
                - '-foo.test'
            default: false
                prefix: '&4'
                suffix: ''
                build: true
                - '*'
            - Admins
            permissions: []
            - Admins
            permissions: []
    When I assign the default permissions by hand like;
            - Default
            permissions: []
    It works just dandy.
  31. Offline


    ummmm. am i the ONLY one who couldnt understand a thing about what the hell am i supposed to do?
    i downloaded the file, put the thingy in the plugins, opened new folder, put the other thingy in that one, changed the name and then what? i fraggen couldnt understand! and how am i supposed to send players a node or what ever its called?

    i put the things in users into globalUsers and same with Groups, but i still cant figure what to do here. if i dont write anything in the permissions, will it let me do everything i want? the hell i dont know anything here?!?!?

    whats whats foo? whats derp? what the hell is every single word in this text! i cant understand it!
Thread Status:
Not open for further replies.

Share This Page