Inactive [ADMIN] Crafty v0.7.6 - Server GUI [1240]

Discussion in 'Bukkit Tools' started by Timberjaw, Feb 3, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Woot, Thanks Man
  2. Offline


  3. Offline


    My gf was watching this right when i clicked on this. This is how i feel when Timberjaw updates
    --- merged: Feb 24, 2011 3:18 PM ---
    .7 fixed scrolling issue.

    suggestion: When i move the scroll bar up to look at something, and a new line is typed, it automatically pulls the scroll bar back down to the bottom. Would be nice if it would start autoscrolling only after i set the bar to the bottom. (or maybe a check box to turn off auto scrolling so i can look at errors.)

    Nice work as usual!
  4. Offline


    As dumb question as it is, is it possible to use this on Windows when the server is located on a Linux VPS? If not, are you going to add this to your to-do?
  5. Offline


    Exception in thread "main" java.awt.HeadlessException
    at java.awt.GraphicsEnvironment.checkHeadless(
    at java.awt.Window.<init>(
    at java.awt.Frame.<init>(
    at java.awt.Frame.<init>(
    at javax.swing.JFrame.<init>(
    at com.aranai.crafty.Crafty.<init>(
    at com.aranai.crafty.Crafty.main(

    Getting this error.
    Running on ubuntu linux 10.10
    Craftbukkit version 431
    running with the command you said on the first post.
    The server runs fine when called directly to the craftbukkit.jar.
  6. Offline


    It's not currently possible. It's something I'd like to tackle, but it's a big project.
    --- merged: Feb 24, 2011 10:52 PM ---
    This error indicates that you don't have a display device, mouse, or keyboard.
  7. Offline


    That doesnt make any sense =S of course I do lol
    Mouse, keyboard and display device =X
  8. Offline


    @prexX It looks like in some cases, OpenJDK on Ubuntu is only partially installed (does not support GUI applications) or buggy. Someone on the Minecraft forums had the same problem on Ubuntu (but with the actual Minecraft client). Their solution was to install the Sun JDK, but you may be able to update or reinstall OpenJDK and get it working (I'm not sure if the distro Ubuntu is pulling from by default has a bad OpenJDK or what).
  9. Offline


    @Timberjaw thks man =) i'm gonna try that tomorrow (got players online atm hehehe) and I'll post some feedback.
    If I actually found the solution, you could add it to the main post in case other players have this problem
  10. Offline


    Absolutely. Let me know what you find out.

    Semi-related: if anyone has a simple .sh equivalent of the included .bat file, I'd be happy to include it in future .zip downloads.
  11. Offline


    Request: automated restart and backup. Due to new save format, files cannot be backed up without stopping server. So this could be done on regular intervals (every few hours):

    1. Server is stopped
    2. All worlds are copied to tmp folder and zipped
    3. destination zip is copied to the destination folder
    4. Server starts again
  12. Offline


    Well here is my .start file. i just type server into terminal and it works, but your .dashrc has to be modified. Anyways heres the file, it updated bukkit to the latest version, renames it, and runs the program.
    cd /media/Minecraft/minecraft_server
    wget ""
    rm craftbukkit.jar
    mv craftbukkit-0.0.1-SNAPSHOT.jar craftbukkit.jar
    java -Xincgc -Xmx2G -jar crafty.jar
    But dont forget to change the cd " /media..." to what folder your server is on.
    and heres my current .bashrc
    # ~/.bashrc: executed by bash(1) for non-login shells.
    # see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
    # for examples
    # If not running interactively, don't do anything
    [ -z "$PS1" ] && return
    # don't put duplicate lines in the history. See bash(1) for more options
    # ... or force ignoredups and ignorespace
    # append to the history file, don't overwrite it
    shopt -s histappend
    # for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
    # check the window size after each command and, if necessary,
    # update the values of LINES and COLUMNS.
    shopt -s checkwinsize
    # make less more friendly for non-text input files, see lesspipe(1)
    [ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"
    # set variable identifying the chroot you work in (used in the prompt below)
    if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
        debian_chroot=$(cat /etc/debian_chroot)
    # set a fancy prompt (non-color, unless we know we "want" color)
    case "$TERM" in
        xterm-color) color_prompt=yes;;
    # uncomment for a colored prompt, if the terminal has the capability; turned
    # off by default to not distract the user: the focus in a terminal window
    # should be on the output of commands, not on the prompt
    if [ -n "$force_color_prompt" ]; then
        if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    	# We have color support; assume it's compliant with Ecma-48
    	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    	# a case would tend to support setf rather than setaf.)
    if [ "$color_prompt" = yes ]; then
        PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
        PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
    unset color_prompt force_color_prompt
    # If this is an xterm set the title to user@host:dir
    case "$TERM" in
        PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    # enable color support of ls and also add handy aliases
    if [ -x /usr/bin/dircolors ]; then
        test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
        alias ls='ls --color=auto'
        #alias dir='dir --color=auto'
        #alias vdir='vdir --color=auto'
        alias ins="sudo apt-get install"
        alias server="./.start"
        alias classic="./"
        alias grep='grep --color=auto'
        alias fgrep='fgrep --color=auto'
        alias egrep='egrep --color=auto'
    # some more ls aliases
    alias ll='ls -alF'
    alias la='ls -A'
    alias l='ls -CF'
    # Add an "alert" alias for long running commands.  Use like so:
    #   sleep 10; alert
    alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'
    # Alias definitions.
    # You may want to put all your additions into a separate file like
    # ~/.bash_aliases, instead of adding them here directly.
    # See /usr/share/doc/bash-doc/examples in the bash-doc package.
    if [ -f ~/.bash_aliases ]; then
        . ~/.bash_aliases
    # enable programmable completion features (you don't need to enable
    # this, if it's already enabled in /etc/bash.bashrc and /etc/profile
    # sources /etc/bash.bashrc).
    if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
        . /etc/bash_completion
    export PATH="${PATH}:/usr/bin"
    export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/usr/lib"
  13. Offline



    It worked.
    After removing OpenJDK and installing the Sun JDK, Crafty works now perfectly.
    Haven't tested it for a long time yet so no bugs or errors so far.
    If anything found, I'll tell ya.

    Thks btw !
  14. Offline


    Crafty v0.7 appears to work after the recent console changes, as of build 452. Build 451 will not work.

    If you're on build 452, you'll notice that each line has a > before it. Will filter that out in the next version.

    Let me know if you encounter any other oddness using Crafty with the new console. I haven't tested thoroughly.
  15. Offline


    You should also include a .command file, like this one, for Mac users.

    Also, does Crafty support command-line args like -w to select world?

    If you replace it with

    cd -P -- "$(dirname -- "$0")" && pwd -P
    It should work without modification.
  16. Offline


    Hey, I can't get this to work on my linux(CentOS 5 32-bit) VPS Machine. When ever I try to run the .sh file I have this in
    cd -P -- "$(dirname -- "$0")" && pwd -P
    wget ""
    rm craftbukkit.jar
    mv craftbukkit-0.0.1-SNAPSHOT.jar craftbukkit.jar
    java -Xincgc -Xmx2G -jar crafty.jar
    it says, "Failed to execute child process "/Minecraft Server/"(No suck file or directory)

    I don't know if I am supposed to be using a .sh file, I just guessed I was because of a above post with #!/bin/sh in the code.
  17. Offline


    As you are running Linux, you should be using a .sh file.

    Are you sure the file /Minecraft Server/ exists?
    Could it be ~/Minecraft Server/
    Where is the .sh file located on your hard drive?
  18. Offline


    @AbsolutePolak That looks a bit more...involved than what I was hoping for. Any chance you have a super-simple .sh file that will work without any other setup?
    --- merged: Feb 27, 2011 2:58 AM ---
    Thanks! Will include this in the next release.

    It should support all of the command-line args Craftbukkit supports. It passes them through. The only arg Crafty intercepts at all is the port arg, which it will optionally use for checking port availability before startup. That shouldn't interfere with the port arg getting to CB though (wouldn't be much point if it did ;).
  19. Offline


    His .sh file just updates CraftBukkit automatically. It won't need any other setup if you change
     cd /media/Minecraft/minecraft_server
    cd -P -- "$(dirname -- "$0")" && pwd -P
    You could also use my file as a .sh file by changing the file type from .command to .sh.

    Cool! I'll be using that in a launcher of some sort.
  20. Offline


    it's been doing this for the last 3 versions, but basically the scrolling is fixed (however it doesnt work like traditional scrolling does. It resets to the bottom every time a new line is outputted, so i cant read anything above the bottom, since it's scrolling every second or so.), just now after so many lines of text, i would say 5000 or so it start to erase the lines from the top at a faster rate then it's printing them on the bottom. Basically if i leave the server on for more then an hour my screen is completely empty or the amount of text in the gui is very very short, like 20 lines.

    I dont see many complaints so I assume this is on my end. What does this run through? I use Windows 7 x64 and java x64. Also most recent version of .netframework. I just can't figure out why this GUI is always bugged for me.

    edit: another error earlier today twice. The gui froze so no text was being scrolled (not unusual, just an all white blank display), the memory consumption was still being used (1800mb/2000), and it said it had 9 or so active users. I could kick people, but noone was acutally online (server was froze). I couldnt log in the server until i closed the gui and restarted the server cb 452 for this error. using cb 455 still getting scroll error but no sign of this freezing error or if it's even from this
  21. Offline


    This isn't a bug per se (it's just the way text panes work in Swing), but it is something I plan on addressing as it's a nuisance.

    This sounds like an unintended side effect of an intended feature. To prevent the text parsing from getting out of control, the output is capped at 1000 lines. It should be removing lines from the top at the same rate it adds them at the bottom. I haven't personally seen the behavior you mention, but I'll try to reproduce it.

    I'm running on Vista x64 and Java 1.6.0_22 64-bit.

    Sounds like a CraftBukkit crash of some kind, but I'm not really sure. You could check your server log file for details if you encounter the issue again.
  22. Offline


    I'm having the same problem as Daveyo.... incidentally my names Dave, but anyways. I can run my server using this GUI which starts up fine then after an hour or so it will have the display blank. I havent been able to watch it go blank just yet so im not sure if its exactly the same as Daveyo's above description. But heres the technical goodies.
    I'm running CB build 445 with 0.7 of crafty GUI. on windows 7 x64 using java 7 64 bit version(maybe its 1.7).
  23. Offline


    There have been several console fixes and changes since 445, including an empty console issue. I recommend updating to 452 or higher and seeing if the issue still occurs.
  24. Offline


    Currently running 465 with crafty GUI. but the server doesnt like the new version of antibuild. I know this isnt the place to ask but know of an alternative. Its really draining my CPU with errors
  25. Offline


    You were right, this isn't the place to ask.
  26. Offline


    Well, What i recomend to do is to just change the directory. Otherwise it wont work since you are running it in home and not the minecraft folder. if you are running the .sh in the minecraft folder, then just delete the cd command entirely. also make sure you are able to execute it as a script.
  27. Offline


    That wasn't helpful nor was it useful. Please refrain from further postings like this. It only aggravates people.
  28. Offline


    to add, I'm also running off a ramdisk with only about 60 megs free space.
  29. Offline


    "Could not find the main class: com.aranai.crafty.Crafty. Program will now exit." Any fixes?
  30. Offline


    Same problem.
Thread Status:
Not open for further replies.

Share This Page