Inactive [ADMIN] Chunkster

Discussion in 'Bukkit Tools' started by XeonProductions, Mar 12, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Boreal

    The server is "CLOSED"...

    The same problem

    [​IMG]
     
  2. Offline

    XRayted

    Did above help you?
     
  3. Offline

    Boreal

    [​IMG]

    excuse me, but is really difficult for me speaking english very well

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 11, 2016
    kano donn likes this.
  4. Offline

    XRayted

    I understand that and those videolinks, I could also understand ;)
    Do you have Java from http://www.java.com and running on Vista or Win7 ?
     
  5. Offline

    Boreal

    I have Java from www.java.com running on Windows XP
    The server works fine me, throw me errors map features
     
  6. Offline

    XRayted

    Ok , I am not sure now. Look at the 'older' pages here to see if you can test those.
    Sorry
     
  7. Offline

    Boreal

    I just need to run the Chunkster
     
  8. Offline

    XeonProductions

    What version of Java do you have installed?
     
  9. Offline

    XRayted

    Good to see you XeonProductions!

    Do you happen to have parameters for Chunkster to fix this?
    Code:
    2011-10-19 13:58:45 [INFO] Chunk file at -14,51 is in the wrong location; relocating. (Expected -14, 51, got -14, 50)
    2011-10-19 13:58:45 [INFO] Chunk (-14, 50) stored at  (-14, 51)
     
  10. Offline

    Redrider923

    hello, i need to run chunkster really bad as it keeps crashing my server. Can someone please explain to me how to run chunkster on a server that your physical computer isn't hosting. I can get to the command prompt on the console, but i dont know how to select the file path. And every command i try i get the cannot access chunkster.jar. From what ive read here that means invalid file path. Can someone please explain how i get the filepath of my server since its not on my pc. I do have the filepath /dev/shm/minecraft/plugins. (thats where my chunkster is currently) I've tried it in what i assume to be the main folder which would be /dev/shm/minecraft right? Someone please help me with this as soon as you can. Would be greatly appreciated.
     
  11. Offline

    meggawatts

    running this on my 3.18 Gb map now, had to use "java -jar chunkster.jar useless_string E:\world"
     
  12. Offline

    Chrisknyfe

    THE FUUU- You're a genius. I was getting the same error, my java version is 1.7.

    Thanks meggawatts!
     
  13. Offline

    xSteven

    Could anyone explain to me how to use this? I don't really understand what im supposed to do.

    EDIT: I get this now

    chunkster: region pointer repair utility v0.1
    usage: java -jar Chunkster.jar world´╗┐ directory
     
    kano donn likes this.
  14. Offline

    XeonProductions

    It's weird, I don't understand why some versions of Java changed how command line arguments are arranged.
     
  15. Offline

    kano donn

    http://i.imgur.com/1NVIb.png

    that link is to the error I keep getting. This error has been reported here and elsewhere and no one knows anything about it.
     
  16. Offline

    XeonProductions

    I'm trying to make a UI version that will make it much easier for people who have no clue how to use command-line.

    I've also just finished a new option that will let you rebuild your entire world. It might even reduce file sizes on heavily corrupted worlds.
     
  17. Offline

    FiiREFUCKER

    Exception in thread "main" java.lang.ArrayIndexOutOfBoundsException: -5
    at java.util.ArrayList.set(Unknown Source)
    at chunkster.RegionFile.<init>(RegionFile.java:141)
    at chunkster.Chunkster.rebuildRegionFile(Chunkster.java:115)
    at chunkster.Chunkster.scan(Chunkster.java:108)
    at chunkster.Chunkster.main(Chunkster.java:87)

    Please .. help
     
  18. Offline

    xDoodleGodx

    it says "cant reach jarfile Chunkster.jar"


    PLEASE HELP!!!!! i did put chunkster in server folder
     
  19. Offline

    XeonProductions

    Did the program keep running after that?
     
  20. Offline

    leetgamer

    Your program just saved my maps from being corrupted. I hate losing my members' creations, it makes me feel horrible.

    So this is me giving a huge THANK YOU to you, my good sir.
     
  21. Offline

    FiiREFUCKER

    Meh. It told me to press any key to close it ;p
     
  22. Offline

    kano donn

    I assume when it reads-
    chunkster: region pointer repair utility v0.1
    usage: java -jar Chunkster.jar <world directory>

    That means im calling the .jar successfully yet not defining the proper world file.

    Yet no matter how I define the path, it throws this out,

    C:\Users\Emerson\Desktop\Chunkster\dist>java -jar Chunkster.jar "C:\Users\Emerso
    n\Desktop\HELP\

    C:\Users\Emerson\Desktop\Chunkster\dist>java -jar Chunkster.jar "C:\Users\Emerso
    n\Desktop\HELP"

    C:\Users\Emerson\Desktop\Chunkster\dist>java -jar Chunkster.jar HELP

    None of those three work. Yes i put the world folder on the desktop and Yes i changed the name of that folder to HELP

    Do I have to put the .jar into the world folder and call it from there?

    A little specs of my machine: I am running win 7 and 64bit java.
     
  23. Offline

    Lighthat

    I still get a corrupt chunk error after running the tool. It's only one chunk, when that specific chunk is unloaded the error stops flooding the console. Want me to send you the world, or is there another way to fix this?
     
  24. Offline

    kano donn

     
    Last edited by a moderator: Dec 14, 2016
  25. Offline

    Boneshock

    Hi i've tried to repair the files i didnt know which is it and i repaired the whole "World" path
    So i'm giving u a link to my "World" path so u can try to repair it .
    http://www.fileserve.com/file/Geqwwz4/world.rar
    i'll be very grateful if repair it
    Thanks in advance .
     
  26. Offline

    chrx1

    I need help !!
    When i start my server i have no problems but when I go to my house i get this and my server crashes :
    [WARNING] Wrong location for [email protected] in world 'cloudcraft'!
    2011-11-01 12:27:21 [WARNING] Entity is at -307.28654595371336,-261.1693445886371 (chunk -20,-17) but was stored in chunk -18,-19
    2011-11-01 12:27:21 [WARNING] Wrong location for [email protected] in world 'cloudcraft'!
    2011-11-01 12:27:21 [WARNING] Entity is at -307.28654595371336,-261.1693445886371 (chunk -20,-17) but was stored in chunk -18,-19
    2011-11-01 12:27:21 [WARNING] Wrong location for [email protected] in world 'cloudcraft'!
    2011-11-01 12:27:21 [WARNING] Entity is at -307.28654595371336,-261.1693445886371 (chunk -20,-17) but was stored in chunk -18,-19
    2011-11-01 12:27:21 [WARNING] Wrong location for [email protected] in world 'cloudcraft'!
    2011-11-01 12:27:21 [WARNING] Entity is at -307.28654595371336,-261.1693445886371 (chunk -20,-17) but was stored in chunk -18,-19
    Can anybody tell me how i can fix that ?

    EDIT : FIXED IT WITH MCEDIT . I Deleted all Enities near my house and now it works fine again :D
     
  27. Offline

    xmagicx60

    Does this work on Linux? My server's main world has a misplaced chunk error, and I can't get Chunkster to start.
     
  28. Offline

    Lolmewn Retired Staff

    Yes it does, I did it once.
    It's basically the same.
     
  29. Offline

    xmagicx60

    Ok, can you tell me where to put it in?
    java -jar Chunkster.jar "/saves/SunCity/"
    isn't working
     
  30. Offline

    XeonProductions

    Try 0.2
     
Thread Status:
Not open for further replies.

Share This Page