Problem/Bug 100% CPU

Discussion in 'General Help' started by JamesCola, Oct 3, 2016.

Thread Status:
Not open for further replies.
  1. Offline


    I bought a host from beastnode 4GB plan today and now when i start it, the CPU becomes 100% and stops server, then repeat same steps for a few times then shut down the server. i tried makin it vanilla but it still doesnt work! is it a scam??
  2. @JamesCola
    Have you tried contacting BeastNode about the issue?
  3. Offline


    @JamesCola Although Beastnode is ridiculously overpriced, no, it is not a scam. Try the following:

    Stop your server.
    Start your server.
    When it's fully started, stop it again.
    Go in to your server files.
    Go to the logs folder.
    Open the file called latest.log.
    Copy and paste the contents at
    Post it there and then link the URL here.

    Also, open your server files, go to the file named eula.txt in the main directory, and make sure that inside that file eula=true.
  4. Offline


  5. Offline


    To me it looks like there's something wrong with Craftbukkit, which is causing it not to load correctly. You should contact Beastnode's support and share that Pastebin with them.

    In the mean time, @timtower do you have any idea what would be causing this?
  6. Offline

    timtower Administrator Administrator Moderator

    @JamesCola @oceantheskatr Users issue maybe, you could try making a backup *very important!* And then removing the world and users.
    Then try again.
  7. An NPE in a NotNull.. well that's interesting. Did you download this jar @JamesCola
  8. Offline


    @bwfcwalshy, if you look at the trace carefully, the server's user cache is corrupted.

    @JamesCola delete the usercache.json file and see if that fixes it. You'll see an error when the server restarts as it regenerates it, but hopefully it will be the last.

    This is usually caused by improperly shutting down the server. You MUST use the stop command to close a server or these kinds of issues can happen.
    ChipDev likes this.
Thread Status:
Not open for further replies.

Share This Page