Bukkit Forums

Oct
23
by EvilSeph at 11:12 PM
(35,465 Views / 0 Likes)
16 Comments
A new CraftBukkit Recommended Build (1.6.4-R1.0) that provides Minecraft 1.6.4 compatibility is now available. As this new Recommended Build also contains a CRITICAL security fix, updating is HIGHLY recommended.

Notable Changes:
Preventing potential structure (stronghold, fortresses, etc.) loss in 1.7
Along with a CRITICAL security fix, Minecraft 1.6.4 also contains a special fix for a problem that could potentially pop up in the future by enabling the saving of generated structures to disk. As such, it is recommended that everyone update to this Recommended Build and explore around the structures you wish to save. For more information on this feature and tips on how to save your structures (as well as a utility you can use to streamline the process), see this announcement.

Re-enabling the built-in auto-save
We've also re-enabled the built-in auto-save...
Sep
19
by EvilSeph at 6:20 PM
(112,971 Views / 26 Likes)
73 Comments
A new CraftBukkit for Minecraft 1.6.4 DEVELOPMENT build is now available!

As of this post, we've shifted development over to Minecraft 1.6.4 compatibility and now have development builds available. We strongly suggest that you only use this build if you would like to help us get a Beta build out sooner and are experienced with using unsupported development builds. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

WARNING: Minecraft 1.6.4 is an update that requires clients to update before being able to connect.

Will plugins break with this build?
Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine. Unless we specifically have to break plugins or the plugins you are using are employing inappropriate practises, most plugins should work without needing an update whenever we put out a new release....
Sep
11
by EvilSeph at 2:06 PM
(50,165 Views / 0 Likes)
159 Comments
It has come to our attention that the plugins "NanoGuard Anticheat" and "InfiniteDispenser" have been distributing potentially malicious code hidden within their update process. We urge all server admins running these plugins or who have run these plugins to read this PSA carefully and follow the advice given immediately.

We strongly advise all server admins to cease using these plugins immediately:
  • NanoGuard Anticheat (Default file name: NanoGuardJAR.jar or similar)
  • InfiniteDispenser (Default file name: InfiniteDispenser-3.2.jar or similar)
As a general precaution, we strongly recommend that all server admins perform a full examination of their server, keeping an eye out for unknown plugins or suspicious behaviour - as is proper on a periodic basis. We also would like to remind server admins to avoid running anything with root or admin privileges without taking the proper precautions to safeguard against the security risks it poses.

In accordance with our...
Sep
10
by EvilSeph at 8:07 PM
(37,962 Views / 0 Likes)
54 Comments
A new CraftBukkit Recommended Build (1.6.2-R1.0) that provides Minecraft 1.6.2 compatibility is now available. As this new Recommended Build also contains a CRITICAL security fix, updating is HIGHLY recommended.

Will plugins break with this build?
Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

Known Issues:
  • None.
For more detailed information on what is contained in this update, please see the changelog here.

Download CraftBukkit 1.6.2-R1.0 here (if this link doesn't work, try this one instead).